[Resolved] How do I install and activate my addon?

Home Forums Support How do I install and activate my addon?

  • This topic has 191 replies, 42 voices, and was last updated 4 years ago by Tom.
Viewing 15 posts - 31 through 45 (of 192 total)
  • Author
    Posts
  • #35833
    Chase

    Do all the plugin files need to be active? because on each plugin only the first set plugin files are active and the rest are not.

    #35835
    Tom
    Lead Developer
    Lead Developer

    Whichever addons you need to use should be activated. You can have just one activated and it will show up in “Appearance > GeneratePress”.

    The email activation is so you can receive automatic updates, so even if you’re not seeing that, the plugins will still work as they should.

    Can you confirm that the addons you have activated are usable, and that the only thing not working is the email activation?

    #35840
    Chase

    the addons don’t show up in the customizer or anywhere else. Right now they are active plugins that don’t seem to do anything. But I meant inside each plugin there are the plug in files (the code) but the only set of code that is (active) is the very first set. The rest are (inactive) and its the same with each plugin. Could that be part of the problem?

    #35844
    Tom
    Lead Developer
    Lead Developer

    I’m not sure what you mean by sets of code inside each plugin being active and inactive.

    Perhaps the files you uploaded and activated became corrupt when you downloaded them.

    Without actually seeing the issue, the only thing I can suggest is removing the addons you’ve installed completely, and download them again.

    Then follow this procedure exactly: http://www.generatepress.com/knowledgebase/install-activate-addons/

    If you follow that with a clean set of addons, you shouldn’t run into any issues.

    #35940
    Chase

    Nothing is working iv installed them and uninstalled them deleted them and downloaded them again. I don’t see how they could be getting corrupted every time. In the wordpress dashboard there is an edit plugin option in the plugins page underneath each one. If you go to the edit page at the top of the page next to the plugin file name it says weather or not the file is active. Most of the plugin files inside each plugin are inactive meaning they are not running.

    #35983
    Tom
    Lead Developer
    Lead Developer

    Okay, so when you go to edit they say they’re inactive.

    So what happens when you click activate? Deactivate? Any errors? Messages?

    #44129
    Ebony Kyle

    Hi Tom I just purchased the generate colors add-on and saved it to my computer, however I am unsure as to where I upload it on my wordpress dashboard. I see a tab that says generatepress but it doesn’t give me the option to upload anything. Can you help me out with this?

    #44130
    Tom
    Lead Developer
    Lead Developer

    Hi Ebony,

    Have you taken a look at this page?: http://www.generatepress.com/knowledgebase/install-activate-addons/

    Basically, you want to take the .zip you purchased, and upload it in “Plugins > Add New > Upload”.

    Let me know if you have any questions πŸ™‚

    #46041
    Peta Elmer

    Hello. I have downloaded my Addons, converted to a Zip file gp-premium.zip which I then managed to install as a Plugin which appears to be activated when I go to Plugins- it’s listed as GP Premium: the entire bundle of Generate Press addons. But now when I go to Appearance-Generate Press I still get the ‘Looks like you don’t have any addons, look what is available’ under Addon Activation. Any suggestions what I might be doing wrong to get these Addons up and running?

    #46224
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    In some rare cases, GP Premium doesn’t recognize that GeneratePress is activated – I’m looking into a more concrete method for the next version.

    If you’d like, you can send me temporary admin access to support@generatepress.com and I’ll get you up and running right away.

    Let me know πŸ™‚

    #51167
    Sandra Robinov

    Hi Tom πŸ™‚

    I am so excited to be changing my theme and so glad I happened upon you! I purchased the premium package of add-ons and that’s where I’m stuck. When I go to “Appearance” there is no “GeneratePress” to carry on adding my email for verification. I feel like I am missing a really stupid step (on my part) but I’m so darn excited to build the thing that I’m already playing around inside the “live preview”. BUT – what am I missing by not having the add-ons.

    I have my key (at your site here), I’m showing that I’m inactive – here and at my site – so please…help??

    Thanks sincerely and most excitedly,
    Sandra Lynn @ informedsharing.com

    #51219
    Tom
    Lead Developer
    Lead Developer

    Hi Sandra,

    If you’re not seeing the “GeneratePress” section under “Appearance”, it’s likely you don’t have GeneratePress installed or activated.

    Once installed and activated, you’ll see that menu item.

    http://generatepress.com/knowledgebase/installing-generatepress/

    Let me know if you have any questions πŸ™‚

    #51222
    Sandra Robinov

    Hi Tom,

    Yah know… I’ve been noodlin’ this for some time (doing offline things) and I thought that might be the issue, lol. Earlier this morning, I was pretty done tweaking as much as I could before hitting save and activate and…well, I still haven’t hit that button. I wanted to hear from you to make sure I didn’t do anything I wasn’t supposed to. Thanks for your answer; going now to follow all that through.

    Sincerely,
    Sandra πŸ™‚

    #51228
    Sandra Robinov

    Okay, Tom – YAY! That worked. Thank you. Though I am live a bit before I wanted to be, lol. I’ll be fine, just some tweaks. One of which, I am asking you… All of my line breaks got broken with the switch (my [ h r ] ‘s ). Will I have to manually go in and fix all of those? I’m sweating at the thought. I haven’t activated all the add-ons yet so I’m hoping???

    Oh, and when I activated the plugin for the add-ons originally, it did say this might mess with my Yoast SEO. What does that mean exactly? I’m doing all this on my own (save the help I receive from geniuses like you) and what I don’t know, I ask. So… πŸ™‚

    Thank you,
    Sandra

    PS: I would love to do a review AND share that and the link to my site, once I’ve finished with this first pretty-ing it up…of course I’ll never be done, lol. But I’ll share the first go ’round πŸ˜‰

    #51230
    Tom
    Lead Developer
    Lead Developer

    That’s odd – your line breaks are broken, or only your <hr /> tags?

    Were you using the HTML: <hr /> – or did your old theme have a shortcode: [ hr ]?

    It definitely won’t mess with Yoast SEO πŸ™‚

    Can’t wait to see what you build πŸ™‚

Viewing 15 posts - 31 through 45 (of 192 total)
  • The topic ‘How do I install and activate my addon?’ is closed to new replies.