Archived topic
400 error on import from library
69 replies · Started by Terence on April 2, 2019
Using EasyWP hosting (part of namecheap) - the theme importer's 400 error message links here but I see no clear resolution or guidance from the dev team on how to fix the Demo site import issue?
Clean install, no other plugins running. Just Askimet and Generate Premium.
None of the demos work but I'm specifically trying to install Java.
Hi Ben,
Have you tried checking for this?
https://docs.generatepress.com/article/error-codes-importing/#400-error
Or Tom's answer here?
https://generatepress.com/forums/topic/400-error-when-importing-from-site-library/#post-1130813
Error 400 is a server sided issue. It's something to fixed on the server side of things as it is outside of the theme's control.
Do you have an XML file for a specific template? Otherwise il have to look for a refund. The demo site was what swayed me :(
Response from Namecheap:
We have checked the issue with our technical team, and unfortunately, the current EasyWP hosting infrastructure does not allow the import to be completed, so we would like to ask you to provide us with the .xml file to import it on our end.
Regarding the cache disabling, to our regret, the EasyWP cache cannot be disabled completely for some time due to EasyWP hosting structure too.
Please check it on your side and let us know if there is anything else we can assist you with.
You can find the XML for java here: https://gpsites.co/files/java/content.xml
However, this method will require some additional setup, as the "Site Options" process can't be completed in the Site Library without the content import completing.
The Site Options process deals with things like:
- Plugin options
- Front page displays option
- Menu setup
Hi - just tried to import the 'volume' site template at got the 400 error at the demo content stage. This is one of the first things I've done for this site so I'm not sure what would be interfering. Is someone available to help please?
Hi Darcy,
There are multiple potential reasons why this occurs.
If you backread on this topic and other topics with the same issue, you'll notice that the culprit and solutions vary.
From Tom:
An error 400 is a security error (no permission), meaning your server isn’t accepting data from our Library.
If:
1. Your site isn’t blocking communication with gpsites.co
2. Your site doesn’t have caching enabled (at the server or WP level)Then you might have other security precautions in place on your server. You may need to check with your hosting to see if there’s anything else that might be getting in the way.
Aside from the recommendation/suggestion here - https://docs.generatepress.com/article/error-codes-importing/#400-error - you can try disabling all of your plugins except GP Premium to check if there are conflicts that prevent you from importing any site template from the site library.
You can also try contacting your site's host for assistance in checking if perhaps they're blocking connections from our site library server.
I have setup a completely fresh install with a spinupwp-hosted WordPress. Getting 400s, if page caching is on, getting 502s, if it is off. This is what I found in the debug.log:
[31-Mar-2021 05:43:46 UTC] PHP Notice: Trying to access array offset on value of type bool in /PATH/wp-content/plugins/gp-premium/sites/classes/class-site.php on line 799
There are known issues with SpinUp WP.
Can you try the suggested fixes of other users found here:
https://generatepress.com/forums/topic/400-error-on-import-from-library/page/4/#post-1370325
and here:
https://generatepress.com/forums/topic/400-error-on-import-from-library/page/4/#post-1386717
Let us know how it goes.
Ha, worked! What I had to do:
- Deactivate Page Caching in SpinupWP
- Deactivate the SpinupWP-Plugin in WordPress
- Temporarily rename
wp-content/object-cache.phpto something like_object-cache.php - Do the import. It works now.
- Reactivate/rename all of the above
Thanks!
Nice one! Glad you got it sorted. No problem. :)
