[Resolved] Missing white space in schema data

Home Forums Support Missing white space in schema data

  • This topic has 4 replies, 2 voices, and was last updated 5 months ago by Anders.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #1469455


    If you look op the schemadata generated, word are putToghter – and does not have awhitespace every time a new headline or paragraf starts…

    This creates unreadable words for google…

    Hopefully you can fix this πŸ™‚

    As usesual – I have created a video trying to explain.

    Lead Developer
    Lead Developer

    Hi there,

    The issue here seems to be because the schema is attached to your entry-content element and you’re adding the title/sub-title to the content, so it’s being parsed as part of your content.

    Not sure why they’re not adding spaces – that part is definitely strange.

    My suggestion would be to disable the structured data as it is now:

    add_filter( 'generate_schema_type', '__return_false' );

    Then use JSON-LD for structured data. Most SEO plugins will have this built in, but there are standalone plugins as well: https://wordpress.org/plugins/wp-structuring-markup/


    Ok, this setup only uses generateblocks and generatepress rc1

    But I will disable the data for know.

    Lead Developer
    Lead Developer

    I’ll dig into it a bit to see if it’s something we can control. I have a feeling this sort of thing would happen with a regular H1 inside your content as well.

    I think JSON-LD is the future vs the HTML markup, anyways. Definitely worth exploring πŸ™‚


    Agree that JSON-LD is the future – Google also made that statement..

    And when using AMP – JSON-LD is choice too πŸ™‚

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.