[Resolved] Weird Shaking

Home Forums Support [Resolved] Weird Shaking

Home Forums Support Weird Shaking

  • This topic has 30 replies, 2 voices, and was last updated 4 years ago by Garth Dryland.
Viewing 15 posts - 16 through 30 (of 31 total)
  • Author
    Posts
  • #360758
    Garth Dryland

    Yes I tried incognito and its still the same.. Sorry.. What video ?

    I’ll also add that the *.mp4 video I emailed you is more descriptive than the initial *.swf

    #360772
    Tom
    Lead Developer
    Lead Developer

    This video: https://www.screencast.com/t/CKzeH78kLpW

    I can see the issue in your video super clearly. The issue is I can’t reproduce it, even inside your installation on the same page. If I can’t see it, there’s not much I can do to diagnose the issue.

    #360805
    Garth Dryland

    OK,

    Given you cant see it I just tried on another computer which uses someone else’s google account and it didn’t occur so its something to do with my computer by the looks of it.

    Pretty sure I’ve deactivated all the chrome extensions in the past and if I did I assume it has to be software or graphic driver related or something like that.

    Can you think of any other possibilities to check into ??

    I will do some more testing. I need to work out what it is. It’s really annoying.

    #360829
    Garth Dryland

    Furthermore to the last post I just found another interesting factor required to recreate.

    My PC is HD display while the other PC is a tablet / hybrid.. its not HD.. Its 1280 x 800 resolution.

    So I checked browser percentage.. Both were 100%

    So I check the graphic card display percentages.

    While the tablet was 100% my HD device was 125% which is the default setting.

    So I set my display to 100% and shutdown everything and rebooted to find the problem was gone.

    So then I set my browser to 125% and the problem came back.

    So it doesn’t matter if the display or the browser is on 125% i get the problem

    Whereas if the browser and display are on 100% or 125% i don’t get the problem

    So assume its some sort of grid issue or maybe similar causing this.

    I’m sure you have a better idea on things to check into now which may resolve this problem.

    The site you have access to is just sitting there so if you want to try something or install/change whatever just go for it.

    You should be able to recreate the problem now so that will help.

    #360853
    Tom
    Lead Developer
    Lead Developer

    Yep, there it is.

    It seems to be an issue with the visual editor – if you switch it to “Text”, it doesn’t happen.

    GP Premium does make adjustments to the visual editor (typically due to the Sections add-on).

    However, the free theme does nothing whatsoever to the editor. None of the meta boxes even using JS.

    I tried using the Twenty Sixteen theme, and the issue is there as well. Looks like it might be a bug inside Yoast – you can report it to them, and tell them to use the Twenty Sixteen theme to test.

    #360881
    Garth Dryland

    Okay

    I’ll link Yoast to this thread and see what comes of it.

    I’ll leave the thread open for now if that’s okay.

    Cheers

    #361895
    Garth Dryland

    Hey Tom

    This is what Yoast sent me. I will see if I can get them to resend the image because I cant read it. Maybe you know where to find this code anyway so posting their reply first which is as follows;

    Thank you for your continued patience. After a lot of testing, we were able to reproduce the issue. However, we can also reproduce the issue when Yoast SEO is not active. Unfortunately, this means something within GeneratePress is causing the issue.

    Below we’ll outline what we’ve discovered in hopes that it helps the GeneratePress developer reproduce the issue.
    The issue appears to happen only when the screen is set to 125% and is on a large screen. We had to maximize our window to consistently reproduce the issue.
    We found the specific part of the code that constantly changes (highlighted in the image below).
    You must scroll down slowly once you hit the bottom of the content window because if you fast scroll, the issue sometimes resolves itself or is less noticeable.
    You must have the full-height editor enabled.
    You must use two columns.
    You must have more length in the main column to cause the second column to become sticky.
    Video of the shaking without Yoast SEO: http://nimb.ws/5CHnad
    Image of the related code https://1drv.ms/f/s!AjEGKOtzUwy1gcgnHf8RFbgEZzPVzA

    PS: I’ve since received the original clear image from Yoast and is linked above

    #361904
    Tom
    Lead Developer
    Lead Developer

    Did you ask them to test in Twenty Sixteen? I was able to get the same effect there.

    It may be a WP bug.

    #361905
    Garth Dryland

    I just asked them that 5-10 minutes ago.

    Waiting on reply which hopefully will come soon.

    If it does, then it must be WordPress itself.

    There’s nothing left to deactivate.

    #361906
    Tom
    Lead Developer
    Lead Developer

    I didn’t notice it in Twenty Seventeen, but did in Twenty Sixteen with only Yoast activated (so it could happen without Yoast as well).

    #361907
    Garth Dryland

    As it does with Generatepress and without Yoast.
    Waiting on confirmation re twenty sixteen theme.

    #361908
    Garth Dryland

    Here’s the latest reply from Yoast which suggests some factors re GeneratePress but points to WordPress core.

    “Thank you for following up on this topic. At first, I could not reproduce with another theme. But I kept trying different things and, finally, was able to reproduce with the Twenty Seventeen theme if the screen was very wide but not very tall ( 1800px x 200px ). So it’s not even specific to GeneratePress, just more noticeable since they add multiple metaboxes. The next step would be to report the issue to WordPress support so they can investigate the issue at the core level.”

    I will email WordPress now and point then back to the thread.

    Cheers for your time. I appreciate it.

    #361909
    Tom
    Lead Developer
    Lead Developer
    #373064
    Garth Dryland

    Hey Tom

    I’m not getting any feedback on wordpress.org Forum in Support » Fixing WordPress.
    Have you posted potential core issues or have an idea where I should point this thread?

    Its going on two and a half weeks now and there’s not one response.

    I thought there would be some interest to work out whats going on given it appears to be a core type issue of some description.

    Do you have any suggestions ?

    Cheers

    #373182
    Tom
    Lead Developer
    Lead Developer

    You can try opening a trac ticket. However, a lot of core devs are likely quite busy with WP 4.9 and 5.0, and since this only happens when you’re zoomed in, they likely won’t look at it. Especially as the Gutenberg editor re-writes the post editing screen.

Viewing 15 posts - 16 through 30 (of 31 total)
  • You must be logged in to reply to this topic.