[Resolved] Updates break site: everything but home page = 404 (localhost)

Home Forums Support [Resolved] Updates break site: everything but home page = 404 (localhost)

Home Forums Support Updates break site: everything but home page = 404 (localhost)

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #250141
    NBC

    I am Mac based, using MAMP 1.9.6.1 under Mac OS X 10.5.8 Leopard. I have set up two sites as localhost installations at /Sites/user/wordpress/

    Each site appears in its own folder, with its own installations of WP and plugins. Each folder contains an .htaccess file, as does /Sites/user/wordpress/, and all three .htaccess files are the same.

    The site at /Sites/user/wordpress/wp2/ still works. Its WP version is 4.6, running GP Premium 1.2.89 and GP 1.3.38.

    The site at /Sites/user/wordpress/wordpress/ will load its home page, but all of its links yield 404s. This is true from previews instigated from the WP dashboard as well as when loading the site on its own. I updated WP and plugins this morning on /Sites/user/wordpress/wordpress/ so all are current. I have not edited the site content itself whatsoever.

    Here are the specs on the problem-child site:
    WordPress 4.6.1 under localhost
    PHP version 5.3.5**
    mySQL version 5.5.9
    ACTIVE PLUGINS:
    Contact Form 7: 4.5.1
    CP Contact Form with Paypal: 5.2.7
    GP Premium: 1.2.92
    RS System Diagnostic: 1.0.2
    Testimonials by BestWebSoft: 0.1.8

    INACTIVE PLUGINS:
    Cart66 Lite: 1.5.8
    Twitter: 1.5.0
    Yoast SEO: 3.9

    **I can’t update PHP past this version without upgrading my OS, and Leopard is the end of the line for my hardware. I do not have the budget for a new system.

    All the content appears in the dashboard, but none of it will load except the home page.

    Any ideas? I really don’t want to have to redo this site or make wholesale changes to it.

    #250145
    Richard Bland

    Thank you NBC for reaching out to us.

    Please allow us a short amount of time to look into this problem further.

    Kind Regards,

    Richard Bland
    Owner, BhambraBland
    --
    w: www.bhambrabland.co.uk
    e: richard@bhambrabland.co.uk
    --

    #250189
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Everything should work with that PHP version – I test back to 5.2.

    You said the home page loads, but the content doesn’t? What shows instead of the content?

    What happens even you re-save your permalink settings in “Settings – Permalinks”? What about if you set them to “Default”?

    #250205
    NBC

    I get a 404 that indicates that localhost can’t find index.html (I’m doing this from memory, as I am away from my desk right now).

    I can’t experiment with the permalink settings till I get home. Putting those back the way I had them is going to be a real chore, I’m afraid!

    #250260
    Tom
    Lead Developer
    Lead Developer

    index.html is completely separate from WordPress itself, so if you can’t access index.html, you’re probably having a server configuration error more than a WordPress/theme/plugin error.

    All of your settings and content still exist in your database, so once you figure out the server issue, your website will be right back where you had it.

    Do you have a live server/anything other than MAMP where you can test the latest version? A few thousand 1.2.92 versions have updated and there hasn’t been any reports of issues like this. I’m leaning towards something going on with your MAMP installation.

    #250290
    NBC

    Except that I have another localhost site using WP 4.6, running GP Premium 1.2.89 and GP 1.3.38 under the same MAMP installation, and it is perfectly fine.

    If I have to reinstall MAMP, I’ll lose my database because it will wipe out the mySQL install along with the rest of the files. If the database is corrupt, urghh. There goes all my work! Poof!

    #250293
    Tom
    Lead Developer
    Lead Developer

    No need to re-install MAMP.

    So what happens if you deactivate GP Premium?

    #250295
    NBC

    I’ll try that as soon as I get home. The sites are on my laptop, which I don’t bring with me when I come to the college to teach.

    You said it sounded like a server error, though, and that would mean a MAMP problem, yes?

    #250296
    Tom
    Lead Developer
    Lead Developer

    Yea, but it would typically be easy to fix. If the home page loads and the other pages don’t load, it sounds like the permalinks are broken.

    In most cases, simply re-saving them will fix that.

    #250313
    NBC

    My hero! I will try resaving the permalinks when I get home.

    Perhaps MAMP only got wobbly with one site because it’s the only one on which I updated anything (WP, GP, GPP, other plugins).

    By the way, that is one really cute kidlet you’ve got there!

    #250315
    Tom
    Lead Developer
    Lead Developer

    Thank you!

    Hopefully re-saving the permalinks does it. If not, we’ll explore other options 🙂

    #250534
    NBC

    [groveling in thanks for easy solution to problem]

    Permalinks it was (or should I say “were”). I brought up “Pages,” clicked on “Quick Edit” for each page, deleted a character from the permalink and retyped it, clicked on the “Update” button, and tested the page.

    YAY!

    Thank you for being quite possibly the most awesome developer anywhere. I’ve seen plenty of companies prattle on about customer support, but you actually do it. In spades. With courtesy, humor, and a smile.

    #250677
    Tom
    Lead Developer
    Lead Developer

    Really happy that everything is back to normal.

    Glad I was able to help 🙂

    #592987
    Fouzie

    Hi Tom,

    I know this is an old thread. I’m not sure where else to look so I thought I’d ask you.

    After updating MAMP on my mac, I suddenly cannot open my website. not even the homepage. I’m entering localhost:8888/(name) and I’m getting “404 Not Found: The requested URL /(name) was not found on this server.” I can see the databases on phpMyadmin, everything looks the same as before.

    Is there a reason I suddenly can’t open my website? I even tried creating a new database but I’m seeing the same error. It’s getting extremely frustrating- please help!

    Thanks in advance for your time.

    Kind Regards,
    Mohammad

    #592993
    Fouzie

    Nevermind! I finally figured it out. For some odd reason, the root file changed by itself after the update. So frustrating, took me ages to figure it out. Thanks anyway!

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.