Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Support request] There are zero fonts in the typography dropdown in the Customize area

Home Forums Support [Support request] There are zero fonts in the typography dropdown in the Customize area

Home Forums Support There are zero fonts in the typography dropdown in the Customize area

  • This topic has 7 replies, 2 voices, and was last updated 3 years ago by Tom.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #556910
    G

    The typography dropdown menu displays “no results found.”

    I had this issue before and support told me to reinstall, which I did. It worked that time. Now there are zero fonts listed to choose from again. I uninstall and re-install and it did not fix it. I have the GP premium.

    I called my host > my memory limit is 256M, so the issue is not that.

    Perhaps, there’s a conflict with another plugin, but I had read several people having this issue as well. All the plugins that I have installed are necessary.

    Perhaps, someone has a solution or I must use a different theme.

    GP Premium 1.6.2
    #556912
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    If you right click within the Customizer and select “Inspect”, are there any red errors under the “Console” tab?

    If not, can you possibly send us temporary admin login details using the Account Issue form?: https://generatepress.com/contact/

    Let me know πŸ™‚

    #557244
    G

    Hi Tom,

    Thanks for your quick reply. I did not see and red errors in the Console tab.

    I have sent an email to “account issue,” with a temp user/pass.

    Awaiting response… Thanks!

    #557296
    Tom
    Lead Developer
    Lead Developer

    There seems to be some sort of plugin conflict going on. A couple things in your Customizer don’t look quite right, and quite a few GP controls are being styled by something else.

    Can you try #1 on this page?: https://docs.generatepress.com/article/debugging-tips/

    #557370
    G

    Hi Tom,

    Yes, the culprit is a plugin that uses API data to write pages on the fly. I guess the code is written to overwrite the WPtheme. I am not a programmer, so i am not quite sure why the developer of the plugin would overwrite the theme’s styling. Maybe it has to do with GPpremium add-on being a plugin. This is out of my league.

    Anyway, I installed Google Fonts plugin and that worked, but it only works for the main content and headers fonts. I’m stuck since the API data (hence plugin) is a must for the site.

    I will be hiring a programmer anyway for other things; so I will have them look into removing the plugin’s code overwrite of GPpremium if possible.

    Any suggestions?

    Sorry for my ignorance; i am a novice.

    #557605
    Tom
    Lead Developer
    Lead Developer

    No problem at all – it’s not an easy one to figure out πŸ™‚

    So the GP typography settings use SelectWoo, which is a “fork” of Select2: https://woocommerce.wordpress.com/2017/08/08/selectwoo-an-accessible-replacement-for-select2/

    It’s possible that their plugin is overwriting that library somehow, which is breaking our controls. It should be something they can tweak in their settings to make sure their plugin is only affecting their settings.

    Is the plugin under active development?

    #558345
    G

    Hey Tom,

    Thanks for getting back to me. Unfortunately, the plugin is not under active development. But the good news is I will pass that tweak info over to the freelance programmer. Hopefully, that would be the resolution.

    Thanks so much for your time and help!
    All the best, G

    #558567
    Tom
    Lead Developer
    Lead Developer

    No problem – let me know if you need further help πŸ™‚

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.