Home Forums Support Theme Version

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
  • #75802
    Lead Developer
    Lead Developer

    That’s giving me a 403 permission error?

    Do you have a security plugin installed? It may be stopping the communication between our servers.

    Garth Dryland

    Sorry I don’t normally have others access to my sites. I do have a security plugin. I just removed whitelisted IPs. That should allow access now.

    When I create a clone and move a site it disables the .htaccess file and therefore the security during the installation creating a std wordpress .htaccess file naming the original one .htaccess.orig so I doubt its that re licencing as it would be disabled at the time.

    I assume the update should be visible when available almost immediate upon reactivating the licence.

    Lead Developer
    Lead Developer

    Can you make sure my account is capable of editing the plugin files? It won’t let me in the editor so I can test the updater.

    Let me know ๐Ÿ™‚

    Garth Dryland

    Not sure what the issue is. I have completely deactivated the security plugin and cleared .htaccess file. The new log in URL is http://test.onlinearchives.net/wp-login.php

    You should have admin access to everything. Do you mean the server itself or just to wordpress?

    I am not sure what you mean by the editor. I’m not aware of any place to edit plugin files in wordpress.

    You have the same level of access as I do. Administrator status.

    Garth Dryland

    I just went and logged into the test site to see if the update was there approx an hour after disabling the security plugin and the GP Premium plugin is now asking to upgrade to v1.1 so it appears to takes some time to pull down the update. It appears to take longer than I first thought.

    I will do some more testing to make sure it is the .htaccess blocking the update. Just wanted to let you know before you waste any more time on this issue. Will update thread as soon as I have confirmation.

    Lead Developer
    Lead Developer

    Thanks for keeping me updated! ๐Ÿ™‚

    Garth Dryland

    I disabled the security plugin on another site and checked the .htaccess has only the wordpress default entries.

    It has been an hour and a half now and the GP 1.1 update has not appeared. I have also deactivated and reactivated the licencing a number of times however it has not helped to pull down the v1.1 update.

    Current GP Premium plugin version is 1.0

    I will check for the update again tomorrow morning, in about ten hours from now.

    Garth Dryland

    Well this is a bit of a mystery. This time I used the production site

    I disabled the security. I waited approx 10 hours and still no GP 1.1 update. I also deactivated and reactivated the licencing but still no change to version.

    So I removed the other test site and cloned my production site and installed it on the test sub domain of which you will have received the log in details for a few moments ago.

    I was shocked to see that the GP 1.1 update was there immediately following the installation.

    The security update was still active. The entries are not in the default htaccess but it appears they still work from the backup htaccess which the plugin creates given I had to log in through the log in page I created within said plugin. This setting resides in the htaccess file, therefore was now residing in the htaccess backup file created following the clone installation.

    So it does NOT appear to be an issue with the security plugin.

    I’m a bit lost with where to go from here. Not sure if you can achieve anything given the update is showing.

    Any suggestions?

    Garth Dryland

    Its looking like I may be able to just run with the latest clone of my production site instead of going back a month and staring again. The clone appears to work perfectly everywhere I have installed it so far.

    BTW – In the last 24 hours (or thereabouts) I have also increased the PHP memory from my php.ini so this may have played some part in why the site clone and installations etc appear to be fine now. It was on 128mb so I tweaked it up to 512mb.

    Once I make some plugin and theme updates (now that I can) and move it back to the production domain I will know either way. Hopefully it works there when I do. Based on some of the random things that have happened so far I will keep my fingers crossed until then. Clearly something weird has been going on when issues aren’t consistent.

    NB: I now believe the security plugin stores some setting outside of the .htaccess file as I have noticed the strength meter sitting at around half way (despite the .htaccess being void of security settings) whereas once I implement everything I believe i can in the .htaccess file the security score sits on 435 out of 460 points.

    So I’m not 100% sure if it blocks the GP Premium plugin or not at this stage. My gut feeling is it doesn’t. I am fairly certain that some sites do pull down the GP Premium update with a score of at least 420 out of 460 points. The remaining 15 points in difference are from blocking the WP XML-RPC API

    Does the GP Premium Plugin use the WP XML-RPC API ?

    Lead Developer
    Lead Developer

    Super weird – I’m not sure what’s going on there.

    I know that if you’re changing URLs completely, you need to deactivate and then activate the registered email again, so it updates the URL in the system.

    The updater uses Easy Digital Downloads Software Licensing, which is pretty widely used – not sure if it uses the XML-RPC API.

Viewing 10 posts - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.