Theme Version

Home Forums Support Theme Version

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #75086
    Garth Dryland

    Hey Tom

    I have just noticed that some of my backups and clones are showing the GP Premium plugin version 1.0 as current, while others are showing v1.1

    I went to check the version on GP.com but I can’t find any reference to the GP Premium plugin version anywhere.

    I have also cross checked the versions of my themes and plugins on all my installs and they are all as they should be except for the GP Premium plugin.

    What version is the GP Premium plugin on currently?

    I also noticed that I have the GeneratePress Child version 0.1 installed but it appears you may have pulled that blank theme and replaced it with Freelancer v0.1?

    I assume this GeneratePress Child theme version is current and cant mess anything up if I leave it installed?

    Any idea whats up with GP Premium plugin on my sites? Has this happened to any one before?

    #75127
    Tom
    Lead Developer
    Lead Developer

    Hi Garth,

    GP Premium is currently 1.1 – I need to add a changelog to the add-on page (on my to-do list).

    Blank theme is still available and correct – Freelancer is just a style I added to WP.org.

    Try deactivating your email and activating again – it should kick the licensing system in the butt to look for the new version.

    Let me know 🙂

    #75137
    Garth Dryland

    Okay, I deactivated, refreshed, activated and refreshed and no changes yet.

    Any other suggestions?

    #75193
    Tom
    Lead Developer
    Lead Developer

    Your email and add-on are “verified” in “Appearance > GeneratePress”?

    Can you send me a temp admin login to support@generatepress.com so I can take a look?

    Thanks!

    #75233
    Garth Dryland

    Sorry i may have mislead you saying that.

    I deactivated the verification and re verified while refreshing to remove any cache to ensure the changes took place however there were no changes with respect to GP Premium seeing the correct version.

    Following re verifying and my last post I also deactivated the plugin and reactivated but no change. I still cant get access to the v1.1 update.

    I have created a temp admin log in which I am emailing to the support account now.

    #75280
    Garth Dryland

    I have been doing a bit more investigating into this issue and it seems that the clone (which CAN suggest to update GP to v1.1) and was made from my production site (which does NOT suggest to update GP to v1.1) using v1.0

    I tested the clone on two sub domains and two additional top level domains and the clone ONLY appears to work one domain (so far). This domain also just happens to be the same domain that I cant seem to stay logged in on when accessing via the wordpress app on my android devices.

    May be no connection at all but thought it may be worth mentioning.

    I may try installing this same clone on my production site/domain tonight (in about 6-8 hours time) to see what happens.

    #75297
    Tom
    Lead Developer
    Lead Developer

    Hi Garth,

    As long as you’ve re-verified the add-on and your email in “Appearance > GeneratePress” then that shouldn’t be a problem.

    If you haven’t, the URL won’t match and the updates won’t be pushed through.

    I tried logging in, but it says the account is still pending.

    #75304
    Garth Dryland

    Oh, maybe I have a setting issue with regards to log in on that backup.

    I have tried the things you suggested some time (hours) ago now but it wont pick up the update.

    I am actually starting to think that there may be an issue with the clones and backups post my build site.

    I am in the process of rolling back to the latest possible build backup pre my production release and will clone that and test it to see if the update appears or not.

    It is possible I didn’t set something in Duplicator plugin and appears is required when moving directories which may not allow some theme/plugins to “port” correctly.

    Sound at all possible to you?

    Do you remember the date you released GP v1.1? It will help my locate the file required.

    #75385
    Garth Dryland

    Okay, so I went back to an original build site backup and cloned that and tested. I did this process twice from the same backup.

    One time I just left GP Premium v1.0 active (v1.1 update was visible) and create a clone.

    The other time I disabled the licence, plugin and theme. (v1.1 update was visible prior to disabling). I then created a clone of that.

    I installed both clones on the same directory at different times and both installs would not provide me access to the GP Premium v1.1 update.

    Everything else site wide seems fine.

    I don’t get it. Any more suggestions?

    #75537
    Garth Dryland

    Perhaps you have a backup with GP Premium v1.0 and can see the v1.1 upgrade and could then install duplicator in an attempt to recreate the issue. Create a clone and install it (the clone) on a spare domain or sub domain to see what happens for you and whether or not the update to v1.1 remains available post the clone installation.

    Maybe you can then see what is causing the issue?

    The reason I use the Duplicator plugin is that 1.) it has well over a million downloads and 2.) its free and 3.) its specified to run on my host (hostmonster) and 4.) the creator of the plugin also uses hostmonster, so it should work really well.

    All other themes and plugins appear to work fine. Many of which I have had updates come in for.

    Your GP theme all seem to work fine. Its just the GP Premium plugin that I’m having issues with.

    NB: I also just had a thought. Maybe you could work with the duplicator creator who i am also going to contact and provide a GP licence, so they can also attempt to recreate the issue otherwise there is likely no way that they can recreate the issue and fix it for other uses of both the duplicator and GP Premium plugins. It may be something to do with their plugin, not yours given the very large number of plugins/themes it needs to be compatible with on WP.org

    #75592
    Garth Dryland
    #75608
    Tom
    Lead Developer
    Lead Developer

    Hi Garth,

    It’s interesting, because the duplicator plugin shouldn’t have anything to do with the licensing.

    When you click “activate” it simply talks to my server to see if the email is valid.

    Once validated, an entry is added to your database with the license key.

    Then, the updater makes sure the license key is valid, and if so, will supply the update.

    Can you activate the username you created for me so I can login and run some tests? I should be able to figure it out – not sure the duplicator dev will be able to do anything.

    Thanks!

    #75641
    Garth Dryland

    So I go and log in to the test site to sort your access and notice the update to GP v1.1 is now showing.

    I have moved and tried dozens of backup and clones in various locations on my server over the last few days but believe the site i sent you access to yesterday is the last clone of my production site, yet i still cant get the update to show on the production site itself.

    So I am currently in the process of rerunning the clone and recreating that site to see what happens and a user account providing I see the update is missing again.

    If it appears straight away then I will probably need to do some more testing before sending you access.

    #75677
    Garth Dryland

    Okay, I have gone way back on my backups until prior to any clone creation/installation (still working on how far back I am going to go, may be a little further yet.) and have confirmed that this particular backup is using GP v1.0 and showing the GP 1.1 upgrade and when cloned and installed on the same domain/dir it works however if I install it elsewhere it may work or it may not. Its random and ever so annoying.

    I cant get the error to happen with the clone used on the previous site I setup the user account for so I have set you up another account with the same details as last time however it is now on the test sub domain not products. I have allowed access in the security plugin so it will work now.

    I can not seem to get the update to GP v1.1 to appear. I have tried verifying licence, deactivating plugin and reactivating etc, etc.

    Hopefully you can see whats going on.

    #75774
    Garth Dryland

    Just realized the log in link may vary in other ways so here’s the latest one.

    http://test.onlinearchives.net/new-login/

Viewing 15 posts - 1 through 15 (of 25 total)
  • You must be logged in to reply to this topic.