[Support request] Scroll Bar is missing on translated pages

Home Forums Support Scroll Bar is missing on translated pages

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1063192
    Filip

    Hi there!

    I am not sure what happend and cant solve this bug in any way I try. Can someone assist me?

    Overall, we did a redesign few days ago, and everything worked fine. The website is built with GeneratePress Premium, Elementor Pro and WPML.

    The issue is that once I change the language (main is Norwegian) to anything else, the website is losing the scroll bar.

    I found that on the affected pages/slugs the top item in the inspection (Html, body) has an Overflow: Hidden value. Once I reset it, the scroll bar appears. But I can’t get to work it once I copy and add the CSS in the customizer or theme child.

    If you zoom out, you can see the content, but can’t scroll down. The weird part is that it was all find and this happened out of nowhere.

    Thank you!

    #1063201
    Leo
    Staff
    Customer Support

    Hi there,

    Does the issue exist if you disable all plugins except GP Premium, Elementor and WPML?

    Have you checked with WPML’s support?

    #1063426
    Filip

    Hi Leo,

    I started with GP Premium, and once disabled, the site is becoming scrollable on the translated languages.

    I did open a ticket with WPML, waiting on a response, but the issue is being solved once GP Premium is disabled. Any solutions to this? Not sure how to control the overflow to prevent this from happening.

    #1063427
    Leo
    Staff
    Customer Support

    That’s very strange.

    Do you have any custom functions added in Elements?

    #1063498
    Filip

    It’s very strange indeed, and I can’t find a solution online.

    There are custom functions, not in Elements from GP as im not using some of the templates, yet there is nothing crucial done within the days this effect becomes active. Is there a CSS trick to get passed this?

    #1063512
    Filip

    I think that this will solve it.

    html, body {
    width: 100% !important;
    height: 100% !important;
    overflow: inherit !important; << added the important part here, works fine now.
    }

    overflow: inherit !important; << added the important part here, works fine now. I`ll leave it here for future reference. Still not sure what changed it.

    #1063520
    Leo
    Staff
    Customer Support

    I’m going to guess that it’s something in the custom functions.

    If you would like to get to identify the problem in the future, then try deactivate all custom function and make sure you are using the parent theme.

    Glad you found a solution for now 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.