[Resolved] Hooks

Home Forums Support Hooks

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #901249
    Rob

    Hi Guys.

    I know this isnt a Generatepress issue, but I thought you may have had this before, or can aim and throw me in the right direction.

    Im using Elementor Pro, to create a Custom Template for the Product Archive.

    I have a Filter plugin, that can assign to Hooks.

    If I disable the Custom Product Template. The Filter appers where I want it, the Hook woocommerce_before_shop_loop. So at the top, near the “sort by” dropdown.

    If I enable the Elementor Template, it disappears. I can only assume Elementor creates its own hook. Would anyone know what that might be?

    I have asked Elementor support, who are refusing to be even slightly helpful.

    Thanks Guys.

    #901364
    David
    Staff
    Customer Support

    Hi there,

    Does the Filter work if you add it to a GP Hook – obviously one that hasn’t been removed by Elementor?

    #901373
    Rob

    Hi David

    I created a similar topic last week, this was for a different site. It worked perfectly after you helped. Its the same plugin, just that I’m using Elementor for custom shop template.

    I have options for “commons hooks”.

    These are:

    https://pasteboard.co/IeYch1u.png

    I then have an option for “custom hooks”.

    as soon as i delete the custom template, resolving back to default shop loop, it works fine.

    I dont know what hooks to try and put in there, thats the issue πŸ™

    #901380
    David
    Staff
    Customer Support

    Hmmm…. lets eliminate a conflict, if you add just some basic HTML to the woocommerce_before_shop_loop does that display?

    #901385
    Rob

    I’ll let you know

    #901391
    Rob

    Still doesnt work πŸ™

    https://pasteboard.co/IeYmMOI.png

    That screen shot it what happens when I delete my Product Loop Template. everything appears.

    #901401
    David
    Staff
    Customer Support

    Looks like Elementor replaces all of the template with just the_content for you to edit. Can the filter be added to the Template using a shortcode?

    #901407
    Rob

    It does come with shortcode, but seems to attach the product loop with it.

    #901414
    David
    Staff
    Customer Support

    Does the default GP Sorting display if you activate that in Customizer > Layout > Woocommerce –> Display product sorting ?

    #901429
    Rob

    Yeah that’s already enabled,

    and disappears if I enable the template.

    #901558
    David
    Staff
    Customer Support

    Are you using a plugin for the product grid? i can see a UAEL- namespace class on those elements.

    #901562
    Rob

    Yes, its the Ultimate Elementor addons.

    #901565
    David
    Staff
    Customer Support

    Looks like it could be related to that, you can test by using the Elementor Product Widget. I know the GP sorting dropdown works on a normal Elementor product archive.

    #901573
    Rob

    Yeah, it seems its the particular widget thats causing the issue. The regular one doesnt have much design option, but it works. So ill just stick with it, thanks again David.

    #901585
    David
    Staff
    Customer Support

    Pretty bad show that they stripped the hook, personally i leave pagebuilders out of woo, its complex enough lol. Glad we found the issue.

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.