[Resolved] Gutenberg + Sections – Issue with HTML in "text" tab

Home Forums Support Gutenberg + Sections – Issue with HTML in "text" tab

This topic contains 20 replies, has 3 voices, and was last updated by  Tom 2 months ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #807541

    Alejandro

    It is not a matter of switching. In fact the code i get when I edit is

    but when i save and publish i get this

    #807867

    Tom Lead Developer

    I was just curious if WordPress was adding anything during the switching process.

    Does this still happen if you take the <iframe> element out temporarily?

    Looking into this more, I’m not sure if it’s possible to prevent, as WordPress adds the paragraphs when the content is output. That being said, I’ve only seen this happen when shortcodes are being used, usually.

    #809922

    Alejandro

    As I am telling you, it is not WP!!. It is GeneratePress Sections Module that creates that problem and that is why I need your help.
    If instead of using GeneratePress Sections Module I use WP HTML block then it works ok.

    I should be able of writing html with GeneratePress Sections Module just like I do in normal WP HTML block.

    Please help.

    #810554

    Tom Lead Developer

    What’s the WP HTML block you’re referring to? In the Gutenberg editor?

    #810996

    Alejandro

    Yes. The default HTML editor block in WordPress 5.0.3.
    It is this one: null
    It is just the normal HTML editor in wordpress when you use blocks.

    As i told you, it is just using GENERATEPRESS SECTIONS that I get the problem.

    I would just give up using your SECTIONS TOOL, but I like the paralax option.

    #811430

    Tom Lead Developer

    Yes, Gutenberg doesn’t have the paragraph issue thankfully.

    I believe the addition of <p> tags is a legacy editor thing, which Sections use. We’re working on a Sections module for Gutenberg, which will fix this issue 🙂

Viewing 6 posts - 16 through 21 (of 21 total)

You must be logged in to reply to this topic.