[Resolved] GP Premium Customizer load problems on SpinupWP server

Home Forums Support GP Premium Customizer load problems on SpinupWP server

  • This topic has 19 replies, 3 voices, and was last updated 4 months ago by Tom.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1502818
    Dimitris

    Hello,

    A few days ago I bought my first GP Premium subscription and I was excited to start building but I came across a disturbing issue.

    I followed the instructions before I open this post + what is mentioned here https://docs.generatepress.com/article/increasing-php-memory-limit/ correcting the file permissions aswel in the wp-config.php file after saving in my SFTP client.

    However, after playing some seconds within the Customizer it doesn’t load. It is a brand new installation with GP Premium and Generateblocks. There are also a small helper plugin from SpinupWP and Limit logins attempted reloaded by WPChef which I don’t think they interfere with GP at all.

    If this issue has occured before please give me the link to fix this damn thing.

    Thanks !

    #1502819
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can disable all plugins except GP Premium to see if that helps with the issue at all?

    Let me know 🙂

    #1502821
    Dimitris

    Hello!

    Thanks for the INSTANT reply. I just deactivated all the plugins except GP Premium and I still get the page not responding error when I make a modification inside the Customizer.

    I am new to WordPress and I would like to know how I can troubleshoot.

    Thanks again for the quick reply Leo!

    #1502848
    Dimitris

    Quick update:

    It seems that either the change takes effect after a prolonged period of time or I get the not responding error. SpinupWP says that they enable page and object caching through Redis on the server level and no caching plugins are required. Through their panel I disabled page cache but I don’t know how to disable object cache.

    In either case, why does this problem appear ? Even if we find a resolution, I would still have to keep caching techniques off?

    Update #2:

    Since it may be a memory problem the $5 Linode with shared cpu and 1 GB of ram may be an issue? Just 2 fresh installations in it and around 150MB of free ram inside the top command. Shall I go for a dedicated cpu at $30 ?

    Update #3:

    I resized my Linode to a vCPU dedicated one and I got way more RAM but still the same problem. Let me know if you have any ideas what is going on.

    #1502884
    Leo
    Staff
    Customer Support
    #1503803
    Tom
    Lead Developer
    Lead Developer

    When you say the Customizer doesn’t load – does it output anything at all? Any errors? Anything in your error_log file?

    It sounds like a server issue – have you had them debug?

    #1504616
    Dimitris

    In debug.log I get:
    [26-Oct-2020 08:51:36 UTC] PHP Notice: Trying to access array offset on value of type null in phar:///usr/local/bin/wp/vendor/wp-cli/extension-command/src/Theme_Command.php on line 473

    In error.log I get:
    2020/10/26 14:19:59 [error] 28512#28512: *33 access forbidden by rule, client: 111.11.111.111, server: xyz.com, request: "POST /xmlrpc.php HTTP/1.1", host: "xyz.com" I replaced host and client for security reasons.

    I checked in wp-config.php and debug is set to true but when I click on the actual site on my google chrome I am not redirected to a debug page.

    As for the error in xmlrpc SpinupWP has 2 options in nginx, one is Disable XML-RPC and the other one is Disallow PHP execution in the uploads folder. Both are set to on and these are for security reasons.

    Generally, the experience is slow within the Customizer and I get a not responding page message from Chrome. When it actually loads (doesn’t show not responding) it takes 3-4 and longer seconds for each change to take effect. I thought it would be instant but I may be wrong as I am new to WordPress.

    In the meantime I will set up a local wp install to check the difference.

    Thank you both for taking the time to deal with my issue. It means a lot to me.

    And Tom, I can’t wait for GenerateBlocks Pro to arrive !

    #1505100
    Dimitris

    Dear Leo and Tom,

    I finally got an error in my browser. It says out of memory in greek (my language). Increasing the limit in wp-config.php was the first thing I did after installing the theme but I increased it again to 256M along with moving to a dedicated CPU Linoe + 4GB of ram (although I only have 2 clean installs with only GP on them).

    Is there a chance that the memory increase is not taken into account? What should I try next? Maybe increase the memory inside php.ini ?

    I already contacted SpinupWP about my issue as I believe it has to do with some configuration.

    #1505296
    Tom
    Lead Developer
    Lead Developer

    Sometimes a server will cap the maximum allowed memory which will prevent your wp-config.php value from being taken into account. It’s worth checking with your hosting to see if this is the case.

    The theme itself shouldn’t use up much memory at all, so it’s possible that something is up with your installation. Testing on another server would definitely be worth a try.

    #1508591
    Dimitris

    Hello Tom,

    I’m sorry for the radio silence but I tried GridPane as the control panel on my linode server. Same issue. When I try for example to upload something from media inside Customizer everything is stuck. Without GP at all a fresh wordpress install runs great. I contacted SpinupWP and I have disabled both server redis caching and page cache.

    I cleared my browser’s cache, I even tried on my laptop but still. I get the error page is not responding and when I click exit instead of wait it says result code hung.

    I can’t understand what I am doing wrong. I have reviewed some other SpinupWP related issues and solutions that other tried but with no success.

    Any ideas in hand would be much appreciated!

    #1509892
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    With the existing debug messages, I’m afraid I don’t have any ideas.

    The theme itself right now is functioning correctly – we aren’t aware of any outstanding issues.

    When you say everything gets stuck – what do you mean? The screen freezes?

    #1511641
    Dimitris

    Dear Tom,

    I tried Nexcess as an alternative option for hosting and I still got the same problem so I switched back to SpinupWP having disabled both page cache and object cache (Redis) through wp-config.php as implied both by the SpinupWP team and Leo above. I have attached the info to have a personal look. Try anywhere to upload an image inside the customizer. Everything freezes.

    I’m really grateful to have support in such a widely used theme. Keep it up guys!

    #1511649
    Dimitris

    Important update!

    I noticed that with GP no problems occur. Customizer loads fast and I can upload stuff like logo and images. When I install Pro and enable activate ALL modules problems arise. I tried activating only backgrounds and I MANAGED to open and use the uploader functionality. I hope this can help!

    #1512690
    Tom
    Lead Developer
    Lead Developer

    Interesting – so if you activate each module one by one, when does it stop working?

    #1512863
    Dimitris

    It works with all except Menu Plus, Secondary Nav, Spacing and Typography. I activated each module one by one and it stuck at all of the above.

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.