[Support request] Generatepress trimming newlines for Code under Tabbed Content(Ultimate Blocks)

Home Forums Support Generatepress trimming newlines for Code under Tabbed Content(Ultimate Blocks)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1277725
    Shadab

    Hi,

    I am using Ultimate Blocks plugin to have a tabbed content. I am posting code examples in different languages under the tabbed content. When I purchased and activated generatepress it trimmed all newlines for the code blocks and my codes are showing inline, hence ugly and not readable.
    For example if you visit my blog and scroll to the part where I am displaying Java/Python tabs and displaying code blocks inside them. You can see all code is being displayed in a single line –
    https://cosmocode.io/java-selenium-tricks-to-locate-elements-like-experts-in-selenium-part-1/

    Please help.

    #1277935
    David
    Staff
    Customer Support

    Hi there,

    What happens if you add the Code Block directly to the editor ie. not inside a the Tabs Block ?

    #1277946
    Shadab

    If I add the Code Block directly to the editor it works well, David. However, with my previous themes, I never had any issue with tabbed content before. So I am hoping you’ll find something for me.

    #1277970
    David
    Staff
    Customer Support

    The problem is related to how the Tabs plugin is ‘handling’ the content of the Code Block.

    If it were a simple CSS fix i could help but the problem is how the editor parses the blocks content. You would need to raise it with the Plugin Author.

    #1278039
    Shadab

    Thanks for the reply. I am afraid if there is an issue with the ‘handling’ of the content of the Code Block by the tabs plugin, how come I never had any issues with any of my previous themes. I am sure before generatepress I tried 8-10 different themes with the same tabs plugin. The issue started only when I moved to generatepress.

    I have over 50 articles, each using code examples at multiple places in the blog. I do not want to go through the pain. Please ask any of your developers to suggest some workaround.

    #1278084
    Leo
    Staff
    Customer Support

    Have you checked with the plugin support to see if they are able to see any issues?

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.