[Resolved] extra space appearing to the right of my Revolution Slider

Home Forums Support [Resolved] extra space appearing to the right of my Revolution Slider

Home Forums Support extra space appearing to the right of my Revolution Slider

Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
  • #770068

    Hi, I’m getting extra space appearing to the right of my Revolution Slider in single posts…
    When I use the standard twenty-nineteen theme all is fine, there’s no extra space, so I think it’s how WP & additions are interacting with GP.

    I’ve been trying to fix for many days so hope there’s a fix you can suggest. I also searched the forums here and tried a few things related to body and .generate-sections-inside-container css but not quite right…
    I would like to give you the private staging site url for you to observe the issue & also the login info privately. (I already sent to Contact account issue.)
    BIG THX!!!!!


    My site uses WP 5.02, GP 2.2.1 and Elementor 2.3.8 pro 2.3.1.
    & I’ve been making some CSS mods using Microthemer.

    THX so very much!!!
    (fingers crossed)

    Customer Support

    Hi there,

    I’ve added the staging site URL link for you in the topic – please do so next time as well πŸ™‚
    We generally don’t need the login info at the start.

    I just checked your site on mobile and not seeing an issue on the right of the slider:

    Am I missing something here?

    Let me know πŸ™‚

    Customer Support

    Looks fine on desktop as well:


    Thanks Leo!…
    though as said was hoping to keep the url private.

    Just swipe to the left to scroll & reveal a lot of white space.
    I think the css code I mentioned fixes things on Desktop Chrome but not on Safari mac nor iPh.



    (I also am concerned that the css
    I added to Customizer > Additional CSS might not be wise to use globally?)

    Customer Support

    The URL field in the original topic is private so only admins/staff can see so it isn’t public:

    The CSS wouldn’t have done anything as you are not using GeneratePress Sections for that page.

    How did you add the content? with some sort of page builder?

    I see something related to micro-theme that might be causing the issue?


    Gotcha on the URL field…

    CSS, gotcha, I just turned off the ‘sections’ css I added.

    The site is wp5, GP & Elementor with Rev Slider…
    The Rev Slider is generating slides via post categories, and each post it grabs has a ‘featured’ image and ‘content’ text. The content text layer in the slider is set to show overflow since the text is below the image rather than on the image.

    This setup has worked for me on numerous sites for years.. but the theme I used is no longer being developed and I’m now on the GP & Elementor bandwagon… The space at right does not show up if I switch to the twenty-nineteen theme so I’m assuming it’s how GP deals with things.

    THX AGAIN for the help!

    edit – what is a ‘micro-theme’?


    oh, the text content I mentioned IS entered via Elementor.

    Customer Support

    Microthemer is making your page extremely messy.

    Can you try disabling that along with all other plugins except GP premium?


    I turned all except essential plugins off..
    (Not surprised Microthemer is messy… bummer though.)
    BUT it still has that space.
    Like said doesn’t happen with other themes… but really want to use GP so please don’t give up on me. πŸ™‚ THX!

    Customer Support

    I also see a plugin called essential grid?

    Can you do the following test:
    – Turn off every plugin except GP premium, not just the essential ones.

    – Start a new single post called GP test and add the slider as content using the default wordpress editor.


    Wow.. OK, turned off ALL except GP and Revolution Slider.. since without RevSldr nothing shows (and I tested with it off and the space is gone of course).


    Customer Support

    Sorry definitely keep Revelution Slider on as well.

    What’s the name of the test page so I can see?


    still space.

    Customer Support

    Thank you for doing the test.

    I can’t quite tell why this is happening as it’s not happening using browser resize.

    I’ve forwarded this to Tom and see if he has any ideas.

    Please keep the current set until he replies.


Viewing 15 posts - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.