[Resolved] Dont display ALL product category tags

Home Forums Support [Resolved] Dont display ALL product category tags

Home Forums Support Dont display ALL product category tags

  • This topic has 5 replies, 2 voices, and was last updated 1 year ago by David.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1484541


    I use Niche theme for the shop https://onemillionluxury.com

    Could you please help me:

    1) To display ONLY subcategory for the Category product page?

    Now I have ALL product category listed at all pages:

    But I need to list ONLY product subcategories.

    2) There are many free space at the desktop after top menu:

    How can I reduce this space?

    3) How to delete woo-brandcamps on product page?

    4) How to delete Quantity field near @Buy@ button on product page?

    5) I want to display small foto under the main foto on Desktop, like it is on mobile: http://joxi.ru/MAjZDdVHkRdOYA
    It is very hard to scroll down large fotos on desktop. Better to have miniatury foto, which I can click to see full size.

    Thenk you in advance!

    Customer Support

    Hi there,

    1. Niche uses a Hook Element to display the Category Navigation. You can find it in Appearance > Elemnents. Edit the element titled: Woocommerce Shop Category menu and replace the code inside with:

    // Setup get_terms product category
    $taxonomy = 'product_cat';
    $current_term = get_queried_object();
    $parent = $current_term->term_id;
    $cat_args = array(
        'parent' => $parent,
        'orderby'    => 'name',
        'order'      => 'asc',
        'hide_empty' => true,
        'depth'  => 1
    // If shop set top level only
    if ( is_shop() ) {
    	$cat_args['parent'] = 0;
    $product_categories = get_terms( $taxonomy , $cat_args );
    // If either exists output terms
    if ( ! empty( $product_categories ) ) {
      echo '<ul class="woo-cat-nav">';
      foreach ( $product_categories as $category ) {
        $term = get_term( $category, $taxonomy );
          '<li><a href="%1$s">%2$s</a></li>',
          get_term_link( $term ),
      echo '</ul>';

    Original topic for reference:

    2. Reduce the Top padding in Customizer > Layout > Container.

    3. Can you share a link to the site so i can see what woo-brandcamps is?

    4. You would need to set the Product to be a single purchase item in the product settings.

    5. You would need to:
    a. Go to Customizer > Additional CSS – delete this:

    /* Stacked Gallery for desktop and sticky summary */
    @media (min-width: 768px) {
    	.woocommerce-product-gallery {
    		display: none;
    	.woo-summary-wrap {
    		display: grid;
    		grid-template-columns: 60% 40%;
    		grid-template-rows: auto;
    		margin-bottom: 80px;
    	.woo-gallery-stack {
    		grid-column: 1;
    		grid-row: 1 / 3;
    	.woo-gallery-stack img {
    		margin-bottom: 20px;
    	.woocommerce-tabs {
    		grid-column: 1;
    	.woocommerce div.product div.summary {
    		grid-column: 2;
    		grid-row: 1;
    		margin-left: 80px;
    		position: -webkit-sticky;
    		position: sticky;
    		top: 105px;
    		bottom: 100px;
    		padding-right: 80px;
    	.single-product span.onsale {
    		position: absolute;
    		top: 0;

    b. Go to Appearance > Elements and delete these 2 x elements:

    Close Summary Wrap
    Gallery Stack


    Thank you very match! All great!

    Additional problems for the website https://onemillionluxury.com/

    1) On desktop FILTER for product categories is empty:

    2) On mobile, top menu (gamburger) is empty too:

    Very hope for your help! Thank you!

    Customer Support

    Thats odd the Site should import the Menu and the Widgets.

    1. Go to Customizer > Widgets –> Off Canvas and add in your Woo Commerce Widgets
    2. Go to Customizer > Menus – select your Menu and set its Location to Off Canvas


    David it is great! I am very happy! Thank you very mutch! You help is huge and the GP Theme is great!

    Customer Support

    You’re welcome – glad we can be of help

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.