[Resolved] cURL error 28: Connection timed out

Home Forums Support cURL error 28: Connection timed out

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1428349
    Linden

    Hello,

    I’m having an issue with GP Premium when trying to activate the license key, it says cURL timed out. I’ve tried to resolve this with my current web host and it seems we’ve hit a bit of a dead end with it.

    I’ve recently moved some of my sites from the shared hosting platform to a VPS (with the same company). When the site was on the shared platform, the license activated fine.

    Here’s what we’ve done so far;

    Deactivated Plugins
    Deactivated Caching
    Increased Memory Limit
    Increased cURL time out
    Installed Query Monitor

    I’m assuming, as it’s worked on their shared platform, there’s no issue connecting to generatepress.com, but I’ll double check with them.

    I know it’s a long shot, but maybe the VPS IP is getting stuck in your firewall?

    IP: 185.151.30.124

    Sorry to open up another thread about this particular issue!

    Thanks,
    Linden

    #1428406
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’ve just checked with our server admins and they confirmed that it’s not banned on our end.

    Perhaps if your hosting support could run a traceroute it would give them or us a hint at what’s going on?

    #1429049
    Linden

    Hi Tom,

    Here’s the reply I’ve had from my hosting support today:

    When we attempt to complete a traceroute to we see that the connection is hanging with them as you can see here.

    Start: Thu Sep 3 11:04:54 2020
    HOST: vps-c3cfda.mvps.stackcp.net Loss% Snt Last Avg Best Wrst StDev
    1.|– gateway 0.0% 2 0.2 0.2 0.2 0.3 0.0
    2.|– 45.8.227.129 0.0% 2 1.0 0.9 0.7 1.0 0.0
    3.|– ??? 100.0 2 0.0 0.0 0.0 0.0 0.0
    4.|– lon-tel-01c.voxility.net 50.0% 2 3.2 3.2 3.2 3.2 0.0
    5.|– lon-tel-01gw.voxility.net 0.0% 2 3.0 3.0 3.0 3.0 0.0
    6.|– 195.66.224.125 0.0% 2 13.0 8.0 3.1 13.0 6.9
    7.|– 108.170.246.143 0.0% 2 3.7 6.0 3.7 8.4 3.3
    8.|– 216.239.58.179 0.0% 2 4.6 4.7 4.6 4.7 0.0
    9.|– 172.253.65.166 0.0% 2 142.6 142.6 142.5 142.6 0.0
    10.|– 216.239.59.0 0.0% 2 140.6 140.6 140.5 140.6 0.0
    11.|– 142.250.231.184 0.0% 2 149.9 146.7 143.5 149.9 4.5
    12.|– 142.250.231.46 0.0% 2 142.3 142.5 142.3 142.7 0.0
    13.|– 172.253.65.95 0.0% 2 142.2 142.2 142.2 142.2 0.0
    14.|– ??? 100.0 2 0.0 0.0 0.0 0.0 0.0

    Thanks,
    Linden

    #1429730
    Tom
    Lead Developer
    Lead Developer

    Thanks for that! Can you try now?

    Let me know 🙂

    #1429755
    Linden

    Hi Tom,

    It still seems to be timing out 😕

    #1429908
    Linden

    Apparently, something to do with the following;

    13.|– 172.253.65.95 0.0% 2 142.2 142.2 142.2 142.2 0.0

    My support guys say it’s not an IP owned by them.

    #1429924
    Tom
    Lead Developer
    Lead Developer

    Not sure what that IP is. Is this issue happening on all your sites on that particular server?

    I’ve recently moved some of my sites from the shared hosting platform to a VPS (with the same company). When the site was on the shared platform, the license activated fine.

    This makes me think there’s some sort of internal firewall set up with the VPS. Are you using something like Cloudflare or Sucuri maybe?

    #1429944
    Linden

    It seems to be just on this particular server. I’m using the same hosting platform for all of my websites and client sites, and they say it’s not an IP in their control which is what is confusing me.

    I’m not using anything other than what 20i supply in terms of Firewall, but this would be what they use across the board – so on the shared hosting platform too.

    It’s certainly an odd one!

    #1430418
    Linden

    Hi Tom,

    They seem to think that your firewall or system may be blocking this IP… 45.8.227.175

    Linden

    #1431009
    Tom
    Lead Developer
    Lead Developer

    Unblocked – can you try now? 🙂

    #1431016
    Linden

    Woohoo! The message of success, it works.

    Thank you 😊

    #1431021
    Tom
    Lead Developer
    Lead Developer

    Awesome! Glad we got it working 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.