[Resolved] css vor primary menu

Home Forums Support [Resolved] css vor primary menu

Home Forums Support css vor primary menu

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1539474
    Martin

    I’ve added css to the primary menu items.
    Everything works, except for the color and the font-weight for the hover (background-color works for the hover).
    Why is this so?

    .hauptmenue {
    width: 150px;
    text-align: center;
    background-color: #009435;
    border-radius: 5px;
    margin-left: 40px;
    margin-top: 10px;
    margin-bottom: 10px;
    }

    .hauptmenue:hover {
    color: red;
    font-weight: bold;
    background-color: #006324;
    }

    #1539518
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    You can use the private information field.

    Let me know ๐Ÿ™‚

    #1544481
    Martin

    Hi,

    the url is:

    I have the same problem with: “:active”.
    The properties that I define for it are also not taken into account.

    Actually, I could do everything with the Thems Customizer. Only there I can’t get any space between the menu entries. So I have to use additional CSS.

    #1544863
    Leo
    Staff
    Customer Support
    #1545582
    Martin

    What does that sound like?

    I only described why I needed additional CSS at all and that the problem also exists with other properties.

    So what should I do with your answer?

    #1545894
    David
    Staff
    Customer Support

    Hi there,

    can you share a link to your site so i can take a look at the issue

    #1547067
    Martin

    Hi,

    I had done that before

    #1548030
    Elvin
    Staff
    Customer Support

    Hi,

    Are you still trying to apply the font-weight on hover?

    If so, you have to apply it on the anchor element(.hauptmenue a) and not the li(.hauptmenue).

    .hauptmenue a:hover{
    color: red;
    font-weight: bold;
    background-color: #006324;
    }

    The color property may have to require the use of !important. But wee recommended setting it on Appearance > Customize > Colors > Primary Navigation.

    A wise man once said:
    "Have you cleared your cache?"

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.