[Resolved] Added Featured Image Manually Via Previous Theme, Now Showing Twice

Home Forums Support [Resolved] Added Featured Image Manually Via Previous Theme, Now Showing Twice

Home Forums Support Added Featured Image Manually Via Previous Theme, Now Showing Twice

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #2324807
    Paul

    Hello,

    Just switched to your theme and love it. Via the previous theme I was using, I added the featured image manually into the top of the post on each post out of necessity of the previous theme. But in your theme, it automatically shows the featured image at the top of the post.

    So now what I have is the same image displaying twice at the top of each post.

    I do not want to Display featured images other than within the post/achieve itself. One time.

    For example, if you look at my homepage (https://i80sportsblog.com/) or any Category page (ex: https://i80sportsblog.com/sports-interviews/) there are no featured images. Only when you click on a post, then you see the featured image. This is perfect and exactly what I want. Other than only wanting the image to appear once.

    Is there a way to accomplish this other than going into every post and manually deleting the additional manually added image?

    I reviewed the following similar support posts and could not find the same issue:

    https://generatepress.com/forums/topic/featured-image-showing-up-twice-on-post/
    https://generatepress.com/forums/topic/featured-image-displaying-twice/
    https://generatepress.com/forums/topic/how-to-hide-featured-images-or-strip-formatting-from-excerpt/
    https://docs.generatepress.com/article/adjusting-the-featured-images/

    Thanks!

    #2324894
    Ying
    Staff
    Customer Support

    Hi Paul,

    You can disable the featured image that theme added at customizer > layout > blog > featured images > posts, uncheck the Display featured imagesoption 🙂

    #2328600
    Paul

    Worked like a dream on majority of posts.

    Noticing on some posts it shows the formatting of the h1 or h2 in the headline, that becomes part of featured snippet text.

    Any way to omit that headline formatting in the feature snippet text?

    #2328648
    Ying
    Staff
    Customer Support

    Can you link me to the specific posts where I can see the issue?

    #2328769
    Paul

    Yes, it looks to be on Category pages:

    https://i80sportsblog.com/racing/
    https://i80sportsblog.com/sports-videos/
    https://i80sportsblog.com/mens-lifestyle/

    Does this have something possibly to do with “Read More” placement/existence?

    #2328865
    Fernando
    Customer Support

    Hi Paul,

    Are you using a More Block for those posts?

    Can you try removing it?

    #2328868
    Paul

    Hi Fernando,

    That did it!

    #2328871
    Fernando
    Customer Support

    You’re welcome Paul!

    #2328918
    Paul

    Appreciate you

    #2328934
    Fernando
    Customer Support

    Have a nice day! Feel free to reach out anytime you’ll need assistance with anything else.

    #2337043
    Paul

    Hello,

    My 2 most recent posts have Featured Images added, but are not showing in the body of the post. All other posts appear to be working perfectly since you helped me.

    https://i80sportsblog.com/2022-nfl-season-predictions-w-nfl-on-fox-mark-schlereth/
    https://i80sportsblog.com/does-the-nfl-preseason-matter-to-anyone-other-than-the-baltimore-ravens/

    Can you let me know how to fix please?

    Also inside the pagebuilder, how can I go from “Paragraph” text to <H2> text?

    #2337474
    Fernando
    Customer Support

    Hi Paul,

    If you hover on Elements in the admin bar while viewing the posts, can you check if there’s a Layout Element or a Page Hero – Block Element?

    Check if any of those is disabling the featured image.

    #2337987
    Paul

    Hi Fernando,

    When I am editing the post within the page builder and I mouse over the Elements selection, nothing happens in terms of Layout Element or a Page Hero – Block Element presenting themselves. And when I click on Elements, it takes me into Appearance–>Elements, where no Elements have been created.

    Within the Post Editor, There is also a Layout option, so I went there. Everything is set to default and non of the Disable Elements are checked.

    If you want me to send screenshots, please let me know what tool to use. Thanks.

    #2338242
    David
    Staff
    Customer Support

    Hi there,

    when you did this:

    https://generatepress.com/forums/topic/added-featured-image-manually-via-previous-theme-now-showing-twice/#post-2324894

    It means that GP won’t show its Featured Image.
    So you would need to add the Image manually as you did with your old theme….

    Ideally it would be good to replace the old themes in content images …. but i could imagine there are a lot of posts to up date.

    #2338880
    Paul

    Makes perfect sense David thank you very much.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.