[Resolved] Woocommerce on mobile displays just one product

Home Forums Support [Resolved] Woocommerce on mobile displays just one product

Home Forums Support Woocommerce on mobile displays just one product

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #880661
    Antonio

    Hi!

    Here I am again with another little problem that I can’t find why I can’t make it work. I’ve checked the forum for answers but no luck so far.

    Using GPP and ElementorPro. Everything updated to latest versions.

    I have set Woocommerce to display 16 products. Everything works just fine in Desktop view, but in mobile and tablet it just shows 1 product, even if in the “Show Result Count” it says “Showing 1-16 out of 170 results”.

    While editing in Elementor it shows the 16 products properly. I have set this section to “show online on mobile”, but I can see all the products, it’s just when I see the live version, the preview version and in the Customize view from GP.

    Do you know why this is happening? Is there a “click” somewhere that I’m missing maybe?

    Thank you very much for your help and advice, feeling more and more in love with this theme.

    GeneratePress 2.2.2
    GP Premium 1.8.1
    #880737
    Leo
    Staff
    Customer Support

    Hi there,

    Your page is under coming soon so we cannot see.

    Are the contents you are referring to coming from Elementor? If so have you checked with their support?

    Let me know 🙂

    #880772
    Antonio

    Hi Leo, thanks for answering.

    I have one user created for Tom, I don’t know if you can get his login info or you want me to create one for you.

    The amount of products is coming from the GP Customize page, like the amount of columns. In the Elementor edit page I can see that section displaying all the products. In the GP Customize page, when I choose the mobile view, then It just shows one product, even if the “Show Result Count” says “Showing 1-16 out of 170 results”. When I save, the live page shows just one product in mobile view.

    Let me know if you want me to create a user for you.

    Thanks!

    #880777
    Leo
    Staff
    Customer Support

    I can just use Tom’s login no problem

    Have you already sent it in?

    Just looked around but didn’t find it.

    You can use the Account Issues here if you haven’t:
    https://generatepress.com/contact/

    Be sure to mention the topic URL.

    #880846
    Antonio

    Sent, thanks!

    #880889
    Leo
    Staff
    Customer Support

    Can you guide me to the page where I can see the issue as the site isn’t in English?

    Thanks 🙂

    #880890
    Antonio

    Sorry, just sent you an email to the support account with the page. Thanks.

    #880902
    Leo
    Staff
    Customer Support

    So those are actually added using Elementor’s widget.

    Can you check with their support first?

    You can see it definitely works with GP’s default setup here:
    http://gpsites.co/seller/

    Let me know what they say 🙂

    #880907
    Antonio

    oh… then I don’t understand, sorry. You say it’s Elementor widget doing that then? But in the Elementor widget there’s no way to set up columns or amount of products. It sends me to the customize panel, where I set up those parameters… here’s picture of the Elementor widget. The only way I can do that is through the GP Customize panel. I’m lost now… 😓

    Elementor widget info

    All the basic set up is done in GP… actually I have some custom CSS that Tom gave me for the Flash Sale tag, that I put in the Customize Panel in GP…

    #880992
    Leo
    Staff
    Customer Support

    I think it’s an Elementor problem as we haven’t had any other reports on this with the default install from GP.

    You can test out these two sites here:
    https://gpsites.co/target/
    https://gpsites.co/seller/

    You can also see that that most of the code is coming from Elementor:
    [screenshot revoved]

    Are you actually using GP’s customizer options here to set the column number?
    https://docs.generatepress.com/article/woocommerce-overview/#shop

    Here are a couple tests we can go through to debug:
    – Try adding a shop page without using Elementor. You can do this within WooCommerce plugin:
    https://www.screencast.com/t/8LDJjL6KqU3r

    Does the product counts show up normally?

    – You can also try activating a twenty series WordPress theme and see if the product counts show up normally.

    Let me know 🙂

    #881499
    Antonio

    Hi Leo, thanks for all the feedback. I’ll start checking everything today, go through those test you recommend and see my options. The main shop page is set up in the woocommerce plugin though, as I didn’t know it could be done any other way…

    Yes the product counts shows normally, like if it was showing all the products in a page (16) while just showing 1. See:

    product count

    Thanks again for your kind help, Leo.

    #881633
    Leo
    Staff
    Customer Support

    So there is already a shop page set up without WooCommerce?

    If so can you link/guide me to it?

    Might be a good idea to disable all plugin except GP Premium and Elementor while testing as well.

    #881650
    Antonio

    Nope, the shop page was already set up like you said, in the Woocommerce settings page is set up to the shop page I sent you via email:

    Woocommerce Setup page

    #881651
    Leo
    Staff
    Customer Support

    That case then try disabling all plugins (including Elementor) but excluding GP Premium to test.

    The default WooCommerce shop page shouldn’t have all types of Elementor added to it.

    I would highly recommend checking with their support. They might already have an idea what’s causing this and save you the headache from debugging.

    #881652
    Antonio

    Ok Leo, I’ll do that, thank you very much. I’ll keep you informed!

    🖖😉

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.