[Resolved] Why is Disable Elements unavailable in GP 2.02 /Premium 1.5.6

Home Forums Support [Resolved] Why is Disable Elements unavailable in GP 2.02 /Premium 1.5.6

Home Forums Support Why is Disable Elements unavailable in GP 2.02 /Premium 1.5.6

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #521236
    Ferdinand

    I’m new to WordPress…. and a bit frustrated.

    I’ve spent all day trying to figure out how to create a homepage distinct from all other pages by having a large (header) logo above the nav menu. In all other pages, a smaller logo would sit in the nav menu at the very top of the page. Surprisingly, neither Global locations, nor Child Themes seems to allow for a separate home page. By the time I found the solution—Disable Elements—it doesn’t seem to be functioning.

    Any help, greatly appreciated.

    GeneratePress 2.0.2
    GP Premium 1.5.6
    #521697
    Leo
    Staff
    Customer Support

    Hi there,

    Disable element should definitely be there in the layout metabox: https://docs.generatepress.com/article/layout-metabox-overview/

    Can you disable maintenance mode so I can see what’s going on?

    #521875
    Ferdinand

    I’ve uninstalled and tried reinstalling Premium 1.5.6 but I can’t seem to avoid getting an error this time—not sure if it’s the same one or not:

    Installing Theme from uploaded file: gp-premium-1.5.6.zip
    Unpacking the package…

    Installing the theme…

    The package could not be installed. The theme is missing the style.css stylesheet.

    Theme installation failed.

    I deactivated the maintenance mode plugin along with every other one including my 1&1 webhost’s. I redownloaded the Premium to rule out corruption in file transfer and tried installing Premium with Forefront active instead of GP 2.02. Same thing. Here’s what the Appearance Editor displays if it’s any help:

    Theme Files
    Stylesheet
    (style.css)
    Theme Functions
    (functions.php)
    css folder
    inc folder
    RTL Stylesheet
    (rtl.css)
    style.min.css
    js folder
    404 Template
    (404.php)
    Archives
    (archive.php)
    Comments
    (comments.php)
    content-link.php
    content-page.php
    content-single.php
    content.php
    Theme Footer
    (footer.php)
    Theme Header
    (header.php)
    Main Index Template
    (index.php)
    no-results.php
    Single Page
    (page.php)
    Search Results
    (search.php)
    Search Form
    (searchform.php)
    sidebar-left.php
    Sidebar
    (sidebar.php)
    Single Post
    (single.php)
    fonts folder
    readme.txt

    #521877
    Ferdinand

    I now see that this is a common error. Hopefully, I’ll have resolved the issue by the time you read this.

    Thanks

    #521985
    Leo
    Staff
    Customer Support
    #522111
    Ferdinand

    Still unavailable after successfully reinstalling Premium 1.5.6 and activating.

    I tried activating Disable Elements alone and in combination with other plugins but it’s still not available in the layout metabox. Might deactivated plugins conflict with activated ones? Could my webhost 1&1 have anything to do with it? I even deleted their ‘1&1 Assistant’ plugin which seems to offer no additional functionality—not sure if that was a good idea.

    #522113
    vr51

    May be related. I noticed in one of my installs of GP 2.0.2 that the GP files failed to transfer properly from the wordpress.org repository. This prevented the proper function of GP Premium. Resolved it by reinstalling GP 2.0.2 from a zip file. Happened only once and that was with one site a couple of weeks ago, not long after GP 2.0.2 was released.

    I see in the thread comments you reinstalled GP Premium. Try reinstalling the main GP theme from zip too.

    #522128
    Ferdinand

    | “Try reinstalling the main GP theme from zip too.”

    Thanks for the tip but after deleting both GP 2.02 and the 1.5.6 plugin, reinstalling them both from zip files, same thing. I notice that whatever Premium plugin components were active when I deactivated and deleted the plugin become active when I reinstall and reactivate.

    #522132
    Tom
    Lead Developer
    Lead Developer

    What exactly makes it “unavailable”? Can you show me a screenshot of the “Layout” metabox? Does the “Disable Elements” item not appear at all?

    #522432
    Ferdinand

    “Can you show me a screenshot of the “Layout” metabox? Does the “Disable Elements” item not appear at all?”

    Here are two screen shots that I made prior to deleting the entire site, plugins and all, and reinstalling everything in order to get back the 1&1 Assistant plugin which I was unable to find on their site but the plugin page informs me is a ‘must’. Still, the same problem exists. In case the problem is due to plugin code corruption, I’ve pasted the code below the screen shots.

    Anything else I can provide to help you help me do the most basic thing: create a home page with a large logo and other pages with just the nav ribbon at the top of the page. It seems such a simple thing but it seems to take me forever.

    #522451
    Leo
    Staff
    Customer Support

    Ahh you are looking at the wrong spot.

    Metabox is on the actual Edit page/post screen: http://www.screencast.com/t/MA5xP9OjR

    #522697
    Ferdinand

    Now I feel foolish. 😉

    But I had come ’round prior to starting from scratch again to wondering why I’d want to disable an element in the (global Theme) Customizer rather than at the (local) page level.

    —-
    Reflections on my misfortune:

    My website is about language. I attribute much of my needlessly wasted time–and yours in responding—to what some call the ‘curse of knowledge’. Now that I know, this seems obvious but it wasn’t at first. So, may I suggest adopting an unambiguous file-naming convention such as the following:

    Company initials _ Product name _ Product type _ Version number
    generatepress.2.0.2.zip > gp-generatepress-theme_2.0.2.zip
    generatepress_child.zip > gp-generatepress_child_theme.zip* OR gp_blank_child_theme.zip
    forefront.1.0.4.zip > gp-forefront_theme_1.0.4.zip (This is the design that I immediately liked.)
    gp-premium-1.5.6.zip > gp-premium-functionality-plugin_1.5.6,zip

    I presume in naming your file, you were following a convention of using the term “premium’ to imply functionality but in your case, it was separate from the actual themes you provide for free. Your naming convention along with my naivety would have initially implied the generatepress_child.zip can only be used with the ‘generatepress’ theme but I doubt that now. It would therefore be to your and your potential customers to rename your files accordingly

    #523109
    Leo
    Staff
    Customer Support

    Glad you figured out!

    Honestly haven’t had too many issues with the naming so it will stay the way as it is for now.

    Thanks for your inputs though 🙂

    #693922
    gianfranco

    please help me. why all has gp202 premium and me not?

    #694003
    David
    Staff
    Customer Support

    Hi there,

    i have responded directly to your other topic

Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.