[Support request] White gap at bottom of page

Home Forums Support [Support request] White gap at bottom of page

Home Forums Support White gap at bottom of page

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #2272908

    Hi there,

    I suddenly have a big white gap at the bottom of my page (tested on different devices) – under my footer.
    It seems to be caused by the plugin “autooptimize” – which i just added – using mostly the settings from the documentation (my cookie plugin needed some parts different.)

    Do you know which setting in the plugin can cause this?

    Customer Support

    Hi Matthias,

    If you disable the plugin, does the issue go away immediately?

    It looks like some CSS class is missing from the slide-out navigation, the plugin might’ve interfered with GP’s JavaScript code.

    Let me know!


    yes – it disappears as soon as i deactivate the autooptimize plugin.

    not sure what you mean by missing css class. The additional css/css i added to child theme style.css?
    Slide-out navigation? If you mean the sidebar plugin – the white gap also appears when i deactivate that one.
    But you seem to be right – as the sidebar (can be slided-out by clicking the contact button on the right side) – also does not work when autooptimize is activated.

    Edit: As your clue made me thinking i tried a little and found the problem:
    Both problems are caused by the “JavaScript Options” of autooptimize – if i disable those they disappear. More precisely:
    The option” Force JavaScript in <head>? Load JavaScript early (discouraged as it makes the JS render blocking)” does cause it. If i deactivate that one it works.

    Customer Support

    Hi Matthias,

    The white space is coming from the Slide out navigation, however, it’s appearing there because it’s being affected by a plugin. Specifically, as mentioned by Ying, some CSS classes for it to work as expected is missing – thus the white gap.

    To clarify, if the sidebar plugin is disabled and autoptimize is kept activated, does the issue disappear as well?

    Also, are you combining/minifying CSS and JS through Autoptimize? If so, can you try disabling this functionality?

    Kindly let us know.


    No – The white space also appears if the sidebar plugin is deactivated.
    It disappears once “Force JavaScript in <head>? Load JavaScript early (discouraged as it makes the JS render blocking)” in autooptimize is deactivated.

    Minified: tbh i dont really understand what im setting in autooptimize 😉 – im using it cause its recommended here – and i use the settings recommended in the docs of gü alongside those of my cookie plugin (there i only added the path to the “exclude from autooptimze” and those in the misc section – the rest is as recommended in the gp docs).

    If by minified js you mean the option “Individual JS-files will be minified and deferred, making them non-render-blocking.” – thats not activated..
    “Aggregate all linked CSS-files? If this option is off, the individual CSS-files will remain in place but will be minified.” – BUT – this also causes some problems with the sidebar plugin – no white gap under the footer – but in the ?header? (under the menu, over the page content). The sidebar plugin works with this – but the vertical contact button i added is displaced in the white gap.

    So with turning those two off it works as wanted.

    Customer Support

    I see. Indeed, some settings in optimization plugins sometimes cause issues.

    I would assume this setting “Force JavaScript in <head>? Load JavaScript early” may cause issues as well. Some JS require for instance jQuery, and if that’s not loaded yet, it would cause issues.

    The same goes for minification of JS.

    If Aggregation of CSS also cause issues, keep it disabled as well.

    For reference, here’s a guideline from GP with regards to Autoptimize settings, but this would be case to case, depending on the plugins included in a website: https://docs.generatepress.com/article/configuring-autoptimize/

    Hope this clarifies!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.