[Resolved] Web Vitals and GP Slowing Things Down

Home Forums Support Web Vitals and GP Slowing Things Down

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1306201
    Robin

    Hey there,

    I just tested my site against Google’s web vitals and the results were horrific. So I got a developer to take a look and he told me:

    “the gp-premium plugin slows down the critical path, and then all the tracking pixels and the many convertbox scripts provide an on-going long-tail”

    Any ideas about how to fix this? If at all.

    On Pingdom my site loads pretty fast but with web vitals it fails miserably.

    TIA

    #1306501
    David
    Staff
    Customer Support

    Hi Robin,

    first thing i notice is the reasonably large number of requests and that there is no combining of CSS or JS files – is this because your on a HTTP2.0 server and its recommended to NOT combine ?

    #1306666
    Robin

    Hmmm. Pass. I don’t know David.

    #1306677
    David
    Staff
    Customer Support

    In that case try the Autoptimize Tips we provide here:

    https://generatepress.com/fastest-wordpress-theme/

    And also in Customizer > General:

    1. Change Icon Type to SVG
    This will remove the font request for the GP Icons
    2. enable Combine CSS
    This will use a reduced version of the Grid CSS that GP uses.

    See how that goes – then we can look at what else can be improved.

    #1306682
    Robin

    Will do, David. Thanks.

    Should I disable W3 Total Cache if using Autoptimize?

    #1306692
    David
    Staff
    Customer Support

    Oh – is W3 Total Cache actually enabled – i can’t see any cached files being served?

    #1306709
    Robin

    Yes it is. I was playing around earlier this morning disabling plugins to see if that made any difference. It didn’t.

    So yup, W3TC is enabled at the moment. Weird it isn’t showing any cache. I’ve had a heck of a problem with it as when I try and post a link to Facebook it doesn’t pull any open graph content and shows no image or any text. I then have to disable it before posting then re-enable it. A royal pain. Hey-ho.

    #1306716
    David
    Staff
    Customer Support

    In that case i would disable W3 and use try out autoptimize

    #1306718
    Robin

    OK, many thanks. Enjoy the weekend and sun 🙂

    #1306792
    David
    Staff
    Customer Support

    You too!
    Let us know how you get on.

    #1308386
    Robin

    Hi David – I can’t find the setting you listed. I’ve been through all the tabs. Maybe the dashboard/interface has changed?

    And also in Customizer > General:

    1. Change Icon Type to SVG
    This will remove the font request for the GP Icons
    2. enable Combine CSS
    This will use a reduced version of the Grid CSS that GP uses.

    TIA

    #1308625
    David
    Staff
    Customer Support

    Thats odd – so there is no Customizer > General visible?

    #1308637
    Robin

    What a muppet. Me not you! Sigh. Senior moment without even being there yet.

    I was looking in Autoptimze not Customizer. It was the ‘z’ that confused me 😉

    Al sorted. Thanks.

    #1309452
    David
    Staff
    Customer Support

    Damn American spelling 🙂
    Glad to to hear you got it resolved

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.