[Support request] Updates not showing on frontend

Home Forums Support Updates not showing on frontend

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #991868
    John

    Hello,

    I have been in contact with David Beckwith in the FB Community regarding my issue.

    I have a site on which I am using Elementor Pro and GPP. I do all my editing using E Pro and they show fine on the backend. But, they do not show on the frontend. I cleared all cache on the site, in the browser and even had the hosting company clear the server cache. None of that worked.

    The only thing that I’ve found that seems to work is to change my Theme, refresh the frontend, then change the theme back to GPP. It has been a persistant issue and I was told to start a ticket and someone can take a look for me.

    I’m not sure what information you need to help me.

    Being a relative rookie to building websites, I just have no idea where else to turn.

    Thank You!

    #991976
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    This sounds like a caching issue. Switching themes can sometimes bust your browser/plugin cache, which is likely why that worked.

    Are you still experiencing this issue if you make some changes in Elementor Pro without switching the theme?

    If so, what caching plugin are you using? Are you using server caching as well?

    #992019
    John

    Hi Tom,

    That is exactly what David Beckwith had told me in the FB Group. The only thing that even resembles caching is something called “Endurance Cache.” However, that is set to “Off Level 0.” I have WP-Optimize installed, but it has never been activated.

    I get the issue with everything thing I try to change. They don’t show on the frontend unless I change the theme.

    This has been a recurring issue over the past 3-4 weeks and it happens with every update I try to make.

    Would it help if I set-up a temporary Admin account for you to look at things? If so, how can I send you the credentials? I really want to continue using your theme and GPP, so any help would be greatly appreciated.

    #992415
    Tom
    Lead Developer
    Lead Developer

    Out of curiosity, what happens if you activate one of the Twenty-x themes and then make changes in Elementor. Does everything update normally without having to switch themes?

    #992489
    John

    I’m writing this in stages as I try different things.

    1. I switched to 2019 theme, no other changes, and immediately my Elementor header disappears. I see only the generic image icon instead of my regular header.

    2. I tried several things. I added a section and changed the background color 3 times, then added a headline and changed the text twice. After that, I added an Icon and changed the color 3 times. After each change, I saved and viewed it on the frontend. ALL changes showed on the frontend.

    In brief summary, other than the Header not showing correctly, all other changes showed immediately on the frontend. I changed back to my GeneratePress Child theme everything appears correctly on the frontend, including the Elementor header.

    I hope that might give you a clue. Thanks for looking into this for me.

    #992549
    Tom
    Lead Developer
    Lead Developer

    Good to know, and now when you make changes in Elementor (and GP), the changes don’t show on the frontend again?

    What if you activate the parent theme instead of your child theme?

    #992556
    John

    As of right now, still using the Child Theme, things seem to be working. Is there any reason why it seems to be intermittent? David had me try a couple of things in the FB group and things worked for a few days. I will try to keep a closer watch on exactly what changes I make in the future and if I have more issues, I will respond to this ticket again.
    Is there any reason why not using a Child theme would make a difference? I’m not a professional, but I’ve always read that I should always use a Child Theme. Not being a professional, I only use Elementor to create everything and any CSS I may use outside of a page specific, I use your Simple CSS plugin.

    #992585
    Tom
    Lead Developer
    Lead Developer

    It sounds like caching, which I know isn’t very helpful. The fact that it works sometimes and not others sounds like the results are cached and not showing.

    I asked about the child theme just in case there was some code in the functions.php that was causing the issue. It doesn’t sound like that’s the case.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.