[Resolved] Sticky menu persists on mobile

Home Forums Support Sticky menu persists on mobile

  • This topic has 17 replies, 3 voices, and was last updated 1 month ago by Leo.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #1415276
    NBC

    I’ve turned off sticky navigation for mobile, but when I check the site on my phone, the sticky menu’s still showing up. (It also shows up in the Customizer’s tablet and mobile previews.)

    I’ve turned off Autoptimize so you can see what’s what.

    [Note: This site’s still running GPP 1.11.2. I’m trying to troubleshoot the WP 5.5 auto-updates, and this site at least thinks it knows how to auto-update GPP. (See this thread for what I’m talking about.) If it’s not updated when I get up on Monday morning, which should be about 4 hours after it thinks it’s going to auto-update, I’ll update it manually.]

    #1415699
    David
    Staff
    Customer Support

    Hi there,

    Odd… could you enable the Customizer > Layout > Mobile Header and make sure its sticky option was not enabled ?

    #1415775
    NBC

    I don’t have a Mobile Header category under Layout in the Customizer. Am I missing something?
    The categories under Layout are as follows:
    Container
    Header
    Primary Navigation
    Secondary Navigation
    Sticky Navigation
    Off Canvas Panel
    Sidebars
    Blog
    Footer

    If I turn on “Hide when scrolling down,” that eliminates the menu from desktop view when I actually want it there.

    I’m sending you log-in credentials so you can see for yourself.

    #1415830
    David
    Staff
    Customer Support

    Oops – i meant Customizer > Layout > Header –> Mobile Header. You will need to enable that option to see if sticky is enabled.

    #1415882
    NBC

    The “Sticky” checkbox on the Header screen doesn’t turn off stickyness.

    #1415906
    David
    Staff
    Customer Support

    Can you resend the login details providing us with temporary admin access so i can look for the issue.

    #1416280
    NBC

    Credentials re-sent. Thank you, David!

    #1416320
    Leo
    Staff
    Customer Support

    Can you provide the admin access so we can take a look at the customizer etc?

    #1416714
    NBC

    Duly updated, Leo.

    #1416723
    Leo
    Staff
    Customer Support

    I’m seeing the stick option On?
    https://www.screencast.com/t/VVpTHQZOYHOg

    Have you tried turning it off?

    #1416741
    NBC

    I want it on for desktop. I have it set to “Desktop only,” but it still shows up on mobile.

    #1416747
    Leo
    Staff
    Customer Support

    We are not talking about the same option here.

    Please take a look at my screenshot above. You have sticky mobile header turned on.

    Turning that off should work.

    #1417217
    NBC

    I had turned that off, Leo, but turning it off had no effect on mobile. (And the way that feature’s labeled makes it look as if it applies to more than mobile.)

    So to recap: That feature is turned off, but the sticky menu still appears on mobile.

    #1417326
    David
    Staff
    Customer Support

    Can you go to Customizer > Layout > Primary Navigation and set the Mobile Menu Breakpoint to 768

    #1417696
    NBC

    That took care of it, David. I’m still not certain why turning off stickyness for the mobile menu didn’t turn off stickyness for the mobile menu 😉

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.