[Resolved] server error 500 inside wp-includes

Home Forums Support [Resolved] server error 500 inside wp-includes

Home Forums Support server error 500 inside wp-includes

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #677984
    Henry Bowman

    This is an ongoing problem we had noticed since we have started a daily close watch in Google search console. Every few months search console will throw us 50-80 500 server errors listed inside “wp-includes” The first few times we thought it was our server even though we could find nothing wrong and no programs or plugins were added or deleted. In a few days, normally after a wordpress, or another plugin like woocommerce had updates, we would see all the server errors disappear. We would ask google search console to re index and the whole process starts over again and each time there was no clear reason as to why the errors were there to begin with or how they were fixed.
    We have attached a screen shot of one of the errors. It seems to be generally inside:
    /wp-includes/widgets
    /wp-includes/customize/
    /wp-includes/SimplePie/

    Has anyone seen this type of behavior and does it seem like it’s related to the theme?
    We are using Generate press Premium version 1.6.2

    - h.k. Bowman

    #677997
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It looks server related to me. Your hosting should be able to investigate by looking into error_logs to find specific errors.

    #678004
    Henry Bowman

    Unfortunately, we run the VPS up to the WHM level.
    When we look at error logs in these directories, the only info was posted at the end of June Here is the error log for “simplepie”:
    [25-Jun-2018 16:10:41 UTC] PHP Fatal error: Class ‘SimplePie’ not found in /home/usanunch/public_html/wp-includes/SimplePie/Core.php on line 55
    [26-Jun-2018 09:33:04 UTC] PHP Fatal error: Class ‘SimplePie’ not found in /home/usanunch/public_html/wp-includes/SimplePie/Core.php on line 55
    [26-Jun-2018 11:23:16 UTC] PHP Fatal error: Class ‘SimplePie’ not found in /home/usanunch/public_html/wp-includes/SimplePie/Core.php on line 55
    [26-Jun-2018 14:34:06 UTC] PHP Fatal error: Class ‘SimplePie’ not found in /home/usanunch/public_html/wp-includes/SimplePie/Core.php on line 55

    Now, I must stress, I’m not a coder, but no changes have been made to any files manually, and if you go to the address above for “Core.php” on line 54-57 you see this:

    class SimplePie_Core extends SimplePie
    {

    }

    - h.k. Bowman

    #678005
    Tom
    Lead Developer
    Lead Developer

    It may be worth upping your memory limit: https://docs.generatepress.com/article/increasing-php-memory-limit/

    That’s core WP functionality which should load just fine. It’s possible that your memory limit is preventing WP from loading fully.

    #678008
    Henry Bowman

    Right now we have PHP 7.0 running at 128M for the memory limit.

    - h.k. Bowman

    #678020
    Henry Bowman

    PS: this may be important. These errors only show up on the “smart phone” side of search console, not the normal desktop listing. We upped the memory limit to 256M but we are still getting these errors. We added the actual error be displayed on the page.

    page: https://usanunchaku.com/wp-includes/customize/class-wp-customize-nav-menu-setting.php
    error: Fatal error: Class ‘WP_Customize_Setting’ not found in /home/usanunch/public_html/wp-includes/customize/class-wp-customize-nav-menu-setting.php on line 21

    - h.k. Bowman

    #678224
    Tom
    Lead Developer
    Lead Developer

    WP_Customize_Setting was introduced in WP 3.4: https://developer.wordpress.org/reference/classes/wp_customize_setting/

    If it’s saying it’s not found, your WordPress installation is incomplete. If it’s not incomplete, it’s failing to load the entire thing. This can happen when the memory limit is reached, but can also be other things. Unfortunately, I’m not a server expert, so I’m not much help when it comes to that.

    #678457
    Henry Bowman

    Tom,
    Thank you so much. Based on your latest info I was able to determine that it wasn’t the WP install, or missing files, or the memory limit. What it turned out to be was some of the PHP ini settings in Aphache were set incorrectly when we migrated from PHP5.5 to PHP7. I discovered it when comparing older versions of PHP 5.5 to the latest we were running at PHP 7. I made the updates to the settings and all the errors have vanished.

    - h.k. Bowman

    #678648
    Tom
    Lead Developer
    Lead Developer

    Glad you found the issue ๐Ÿ™‚

    #688140
    Henry Bowman

    UPDATE: It turned out that the PHP upgrades did nothing but mask the error on Firefox and Edge, Google chrome was still showing the true problem. Here is what we discovered:
    The directory indexing of the site was mistakenly set “open” or index-able at some point in the past. During that time a hacker scraped our site, and google search console tried to index all the contents of WordPress directories and files that are not meant to be placed on a browser page by themselves like “wp-includes” These pages or not meant to be “displayed and can not be without displaying throwing an error.
    The solution was to of course turn off indexing. Shore up the robot.txt and .htaccess files and wait out google search console to stop looking for files it doesn’t need to display our site.

    - h.k. Bowman

    #688171
    Tom
    Lead Developer
    Lead Developer

    Ahh – thanks for letting us know what was going on! Appreciate it ๐Ÿ™‚

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.