[Resolved] Password Protected Pages Don't Work Correctly

Home Forums Support Password Protected Pages Don't Work Correctly

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1211247
    Marci Carter

    I have multiple pages on my site protected by a password using the built-in WordPress visibility settings. When I first built my site this functioned perfectly, but in the last month or so entering the password almost always results in the page reloading with the “enter password” box still there. It doesn’t give an error message, it just doesn’t reload the page to show the protected content. After about 30 seconds or so, if I reload the page it will sometimes show the content but sometimes not. This happens on all browsers, both desktop and mobile, and using different ISPs. I have tried clearing the cache. I have tried turning off all plug-ins one at a time, but the problem still persists. Any ideas on what might be causing this? I’m happy to give you the password if there is a way to do it privately?

    #1211259
    Leo
    Staff
    Customer Support

    Hi there,

    This is unlikely a theme issue as that’s a WordPress function.

    Does the issue exist if you activate a twenty series default WP theme to test?

    #1247352
    Marci Carter

    Hey Leo,
    Sorry for the delay in responding. I’ve been doing some exhaustive research into this, with the help of a developer, and I’m pretty sure we’ve figured out where the issue lies.

    For some reason, GP Premium (possibly just version 1.9.1) combined with GoDaddy shared WordPress hosting is causing the basic password-protect WordPress function to not work. I moved the entire site to a dev environment I have on a different host, WP Engine, and the password functionality works perfectly. But on my GoDaddy hosting, it only works if I turn off GP Premium.

    Even if I switch to a different theme, like Twenty Nineteen, the password functionality still doesn’t work unless I deactivate GP Premium.

    When I initially built the site this problem did not occur, but that was an earlier version of GP Premium.

    Could you guys look into this and see what might be causing the incompatibility?

    In the meantime, would you recommend that I revert to an earlier version of GP Premium? Or possibly try the Version: 1.10.0-rc.2 Beta?

    #1247761
    David
    Staff
    Customer Support

    Hi there,

    can you try testing it with the GoDaddy CDN disabled?
    We have seen some awfully bizarre occurrences with a couple of users and after much back and forth it turned out that was causing the problem. Considering CDNs make changes to DNS it sounds like it could also be behind this. Let us know.

    #1248516
    Marci Carter

    Hey David,
    Unfortunately, disabling the GoDaddy CDN did not fix the problem.

    #1248922
    David
    Staff
    Customer Support

    Can you send us a password to test – you can send it via the Account Issue form:

    https://generatepress.com/contact/

    Please add the URL of this topic to the form so we can track.

    #1249634
    Marci Carter

    Absolutely. I just submitted the Account Issue form.

    #1250081
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    I’m getting a “Service Unavailable” error when I try to enter the password.

    It’s unlikely that GP Premium would be causing this, simply because there isn’t any code related to the password protection functionality.

    What happens if all of the GPP modules are turned off in “Appearance > GeneratePress”?

    #1250134
    Marci Carter

    When I deactivate all the modules, the problem still persists. But when I deactivate the entire plugin, the problem instantly resolves and the password works every single time. It’s the only thing that fixes the problem. Even when I have every single other plug-in turned off, having GP Premium on causes the problem (but again, only on GoDaddy hosting).

    I just tried reverting back to older versions of GP Premium to see if that would help. Once I got to Version 1.5.6, the problem disappeared and the password worked every time. So, I’m seeing the issue on Versions 1.7.7, 1.8.3, 1.9.1, and 1.10.0. Does that possibly offer any clues? (I’ve got the site back on 1.10.0 right now).

    I’m not sure that it’s actually a problem with the password, but rather some sort of issue causing the page to not reload correctly or some sort of strange caching issue.

    I’m happy to provide you with a login to the backend so you can see it firsthand.

    #1251622
    Tom
    Lead Developer
    Lead Developer

    If none of the modules are turned on, there are very few functions that are actually executing in GP Premium.

    There are a handful of files that are included even with the modules turned off, but I’m not seeing anything that would cause this issue, especially only GoDaddy.

    Are you comfortable editing core files at all? I can give you instructions to comment out certain files that are still loading if you’re willing.

    #1251790
    Marci Carter

    Yes, that would be great.

    #1252343
    Tom
    Lead Developer
    Lead Developer

    Let’s give it a go..

    In wp-content/plugins/gp-premium/gp-premium.php, look for and delete:

    require_once plugin_dir_path( __FILE__ ) . 'general/smooth-scroll.php';

    Any difference? If not, put it back and look for and delete:

    require_once plugin_dir_path( __FILE__ ) . 'general/icons.php';

    Other than that, there is nothing else running on the front-end of your site if all modules are turned off.

    #1254197
    Marci Carter

    Tom,
    Commenting those out did not fix the problem. However, I went back in to try disabling the modules again (just to double-check myself) and discovered that those deactivations were not always being applied to the live site, even when using private or incognito windows and performing Empty Cache/Hard Reload.

    Turns out, GoDaddy server cache was causing those module deactivations to not “go live.” After going in and manually flushing the GoDaddy cache every time I made a change, I was able to discover that deactivating the Elements plug-in actually does fix the password issue. I apologize for giving incorrect information on that before.

    Any idea what might be going on to cause this? I use an element header on almost every page, so I’d really love to be able to continue using that module.

    #1254375
    Tom
    Lead Developer
    Lead Developer

    That makes more sense! Now it’s time to “Draft” those Elements one by one to see if one of them is causing the issue 🙂

    #1254385
    Marci Carter

    Yep, that was it. I had a hook element for my Google Analytics, and that’s what was causing the issue.

    Thank you so much for your patience and help. I’m kicking myself for not figuring this out on my own. Hahaha! Seriously, you guys are rock stars.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.