[Resolved] Page Jumps – Page Padding/ Margins Different on Different Pages

Home Forums Support [Resolved] Page Jumps – Page Padding/ Margins Different on Different Pages

Home Forums Support Page Jumps – Page Padding/ Margins Different on Different Pages

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1974246
    Laurie

    Hello,
    I hope you are all well;
    I have just started to put together a new site and have noticed that when I navigate between various pages the headings/ navigation it appears to “jump”, I thought it was perhaps due to the padding being different on the pages.

    Having spent some time trying to find where the problem was I thought I would ask the professionals! (that way hopefully I will know in the future as I have had this before and rebuilt all the pages, I am sure it must be something that I cannot find?)

    Home Pages
    https://scotland.grantschemes.co.uk/

    Page jumps (top of text page title/ navigation labels in left column jumps if you click between “Home” and “Boilers”
    https://scotland.grantschemes.co.uk/boiler-grants-scotland/

    Many thanks for your help.

    Best regards

    L

    #1974326
    David
    Staff
    Customer Support

    Hi there,

    if you edit this: https://scotland.grantschemes.co.uk/boiler-grants-scotland/ page

    Do you have the Content Title Disabled ?

    #1974371
    Laurie

    Hello David,
    Thank you for getting back to me, in both pages to which I referred the title is “hidden”.

    With regard to hiding the WordPress generated title, I usually hide the title and add a new H1 Heading, is that an acceptable practice for SEO or am I better off having the page title “Not Hidden” and using that instead of adding a new H1?

    Many thanks

    L

    #1974410
    David
    Staff
    Customer Support

    Just to be clear – is it the Disable Elements box you’re using to hide the title ? See here:

    https://docs.generatepress.com/article/disable-elements-overview/

    Not a problem hiding the template H1 Content Title and adding your own 🙂

    #1974436
    Laurie

    Hello,
    I have tried to check but do not see the “options” box in tools to enable it in the “Settings”

    No Layout Option

    #1974447
    David
    Staff
    Customer Support

    It should be in the right sidebar for the Page settings, somewhere at the bottom of the list.

    #1974453
    Laurie

    as you can see from the image, in the “Tools” section – it is not there, I have tried disabling it and re-enabling it in GP setting?

    #1974551
    David
    Staff
    Customer Support
    #1974788
    Laurie

    I have the box above it (Page Attributes) but no “Layout Section” – it is not there!

    #1974793
    David
    Staff
    Customer Support

    Well thats odd… is it by any chance hiding at the very bottom of the page editor screen if you scroll to the bottom?

    If not – how did you Disable the Content Title ?

    #1974838
    Laurie

    https://scotland.grantschemes.co.uk/wp-content/uploads/2021/10/Option-Box-2.jpgScreen Shot 2

    Hello,
    I have added an image for you, I have scrolled to the bottom of the panel on the right, it is not there, I have read the description in your text and there is no option to enable eit/

    I have also checked on the GeneratePress settings and it is enabled?

    #1974850
    Laurie

    Hello,
    Just for information, I have checked some other sites I have built with GP, the “Disable Elements” box is no longer showing on any site? – (I know what it looks like, I use it all the time).

    #1974871
    Laurie

    Hello,

    I have found it – I disabled the plugins and it has now “Layout” has appeared under the main page editing section (see image) it was not there before because I looked there too! – I have tried to get it back in the right-hand column but does not want to go there, how can I do this, please.

    Found in main editing area

    #1974872
    David
    Staff
    Customer Support

    If you scroll to the bottom of the post editor ie. the content and not the sidbar does it show below there?
    If it isn’t then maybe another plugin is conflicting with it.

    So the odd part – when you use the GP Disable Element Content Title it removes the Entry Header HTML from the page ( the option you’re using isn’t doing that ). On your page with the ‘correct’ padding that HTML has been removed, but its not been removed from the Other page which is where the additional padding comes from. Which kinda says the first page the title disabled using GP ….

    Do you remove the Content Title from All Pages ? If so you can use a Layout Element to apply it to ALL pages.

    #1974881
    Laurie

    Hi David, Yes, now I have found it if I disable the header from there and not where I was doing it before I can get the pages to “behave” – I have found some extra padding in one of columns so will remove this from the other pages and we should hopefully all be bacj to the same layout,

    Yes, something was conflicting with it – I disabled and re-enabled some of the plugins and it is still in the main editing area as you can see, – Isa there any way to put it back in the right-hand column?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.