🎉 Happy 4th of July! Get 15% off GP Premium with the discount code: 4THOFJULY2020

[Support request] Non-amp site display is ugly – not same as customized

Home Forums Support Non-amp site display is ugly – not same as customized

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1346895
    Kong Thiam

    GP site display is always good until last Friday 26 June the desktop site display turns ugly as the attached file. This incident has caused my ranking dropped from 32.3 to 33.7. Please act fast.
    Why this sudden happen? Is it something wrong with my doing?

    #1347282
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    It almost looks like none of the CSS is being parsed.

    This can happen if there’s an error in it somewhere.

    You can run your site through this tool to check: https://jigsaw.w3.org/css-validator/

    I’m seeing a parse error in the block library CSS file that is from WordPress/the Gutenberg plugin. Did anything change in regards to that recently? Perhaps you’re using the plugin and an update is conflicting with AMP?

    #1348918
    Kong Thiam

    Dear Tom,

    There is 111 warning in the link below.
    CSS validation result

    Three errors:
    .wp-gs .wp-block-button__link:not(.has-background) Value Error : background-color Parse Error var(–wp-block-core-button–color–background,var(–wp-color–primary,#32373c))

    .wp-block-buttons.alignright .wp-block-button Value Error : margin-right none is not a margin-right value : none

    .load-more:not(.has-svg-icon) .button.loading:before Value Error : speak none is not a speak value : none

    I am out of knowledge to act. Please help.

    #1348929
    Kong Thiam

    Dear Tom,

    Your baby is cute.

    I found “Simple CSS.” Download and installed on the website. But editing gets a warning, not allowed to do. How?
    I cannot send an image file here.

    Best Regards
    Stephen

    #1349206
    David
    Staff
    Customer Support

    Hi there,

    can you try installing the Gutenberg plugin:

    https://en-gb.wordpress.org/plugins/gutenberg/

    this should install the latest version of the block editor and a new CSS file for the blocks.

    #1350188
    Kong Thiam

    Dear David,

    Can I not use the Gutenberg plugin? First I am not familiar and second add one plugin, I am facing Java Script again.
    Why Generate Press is not working since 26th June only? After purchase Pro, nothing can help. Can solve without adding any plugin?

    Best Regards
    Stephen Tan

    #1350448
    David
    Staff
    Customer Support
    #1351203
    Kong Thiam

    Dear David,

    Can I not use the Gutenberg plugin? First, I am not familiar and second add one plugin, I am facing Java Script again.
    Why is Generate Press not working since 26th June only? After purchase Pro, nothing can help. Can you solve it without adding any plugin?

    Best Regards
    Stephen Tan

    #1351372
    David
    Staff
    Customer Support

    GeneratePress has not changed and would not break your site.
    This means something else has changed on your site.
    We need to eliminate what could have changed.
    This means first to disable any other plugins to test if they are the problem.

    #1351498
    Kong Thiam

    I guess the Asset CleanUp plugin is causing GP display to change at the end of June due to unloading GP style CSS. The second new plugin is SMUSH, which I installed after Asset CleanUp. But I do not think SMUSH can cause GP loss Style CSS, Am I right?
    The old plugin has been working well with GP for quite a long time.
    I hope to delay the test for a few days to see the effectiveness of Asset cleanUp. May be next Wednesday, I will try to disable Asset CleanUp to know the result.

    #1351903
    David
    Staff
    Customer Support

    The best thing is to temporarily disable all other plugins.
    Asset CleanUp and any Cache or Optimization plugins are likely to be causing the problem.
    I do not think Smush could create the issue.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.