[Resolved] Ninja Form Not Loading / SyntaxError: Unexpected Token

Home Forums Support [Resolved] Ninja Form Not Loading / SyntaxError: Unexpected Token

Home Forums Support Ninja Form Not Loading / SyntaxError: Unexpected Token

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #666274
    Kurieuo

    I’m opening a new topic, however having a similar issue to what was reported here: https://generatepress.com/forums/topic/ninja-form-not-loading/

    A Ninja Form Widget has been padded as a Footer Widget via customiser. It works when it is the only form on the page, but if I display another form as part of the page content (e.g., Contact page), then the ninja form footer widget keeps on trying to load. Chrome Dev Tools reports, Uncaught SyntaxError: Unexpected token <

    I couldn’t find any issue raised over Ninja Forms re: this, but found threads here with some reported issues. I think perhaps there is a conflict between the way Ninja Forms does things and way Generate Press does things, grid related perhaps? – rather than this necessarily being a bug.

    I may just go with Contact7, but any ideas just off the top of your head as to a quick fix? Happy to edit code.

    Thanks.

    GP Premium 1.7.2
    #666299
    Leo
    Staff
    Customer Support

    Hi there,

    Can you try #1 here to eliminate any plugin conflicts first?
    https://docs.generatepress.com/article/debugging-tips/

    If not then try #4 in the same article so we know for sure it’s not a problem from Ninja Forms.

    Let me know 🙂

    #666369
    Kurieuo

    Sorry, seems to be a Ninja Forms bug. It’s repeating across different themes if the widget form is added.

    #666706
    Leo
    Staff
    Customer Support

    That case their support should be able to help you out.

    No problem 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.