[Resolved] Mobile menu

Home Forums Support [Resolved] Mobile menu

Home Forums Support Mobile menu

  • This topic has 21 replies, 4 voices, and was last updated 1 month ago by Fernando.
Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #2274496
    Philippe

    Hi,

    My website is onehomeplanet.com

    The menu may or may not work on a smartphone screen. It seems to be totally at random (is this a clue?).

    Thanks for your help,

    Philippe

    #2274533
    Fernando
    Customer Support

    Hi Philippe,

    More often than not, issues like these stem from a specific setting in optimization/caching settings.

    As a first course of debugging, can you try temporarily deactivating any caching/optimization plugins you have like autoptimize?

    If the issue disappears, we’ll be able to confirm that a specific optimization/caching is causing the issue.

    Usually, these issues are caused by any combination/minification of JS. Try disabling any JS optimization like this in your optimization/caching plugins.

    Clear all caching mechanisms set in your website afterwards. Clear CDN and server side cache as well: https://share.getcloudapp.com/E0uyg0QA

    Kindly let us know how it goes.

    #2274600
    Philippe

    Hi Fernando,

    I have deactivated Autoptimize and Super Page Cache for Cloudflare. These are all the cache features I have. The menu now works on my smartphone (as well as the scroll back up button).

    Can you guide me on what to check out first when reactivating the plugins?

    Thank you.

    #2274718
    David
    Staff
    Customer Support

    Hi there,

    don’t activate any Javascript optimizations in Autoptimize or any of the other plugins.
    If the menu works ok, then enable the JS optimizations one by one.

    #2274762
    Philippe

    Hi David,

    It is a mess.

    The website menu will remain fully activated on a smartphone, only if I totally deactivate both Autoptimize and Cloudflare plugins.

    #2274782
    Philippe

    The Cloudflare plugin I am referring to is Super Page Cache for Cloudflare, not the Cloudflare plugin itself. I am going to see what I can find on the Cloudflare side.

    #2274803
    David
    Staff
    Customer Support

    I would suggest you speak with Autoptimize, Frank ( the author ) should be able to advise on the best settings for it to work with the Cloudflare super page cache.

    #2274814
    Philippe

    Ok.

    #2274821
    David
    Staff
    Customer Support

    Let us know how you get on!

    #2274986
    Philippe

    I will. 🙂

    #2275055
    Philippe

    There is progress.

    I found this: https://flashlearners.com/autoptimize-configuration-settings/

    And did that: Disable Minify on Cloudflare: Untick JavaScript minify, CSS Minify and HTML Minify.

    Now the website menu and the scroll back up button work on posts on a smartphone screen, not on pages. Any idea why would that be?

    #2275129
    Ying
    Staff
    Customer Support

    Hi Philippe,

    Just tested your site on my phone, and it seems the menu still doesn’t work.

    It looks like some JavaScript is messed up by the cache plugin.

    Please try to do more testing with your cache plugin or reach out to the cache plugin’s support.

    #2275158
    Philippe

    Hi Ying,

    My only cache plugin is Autoptimize. I let them know I need to get in touch with them.

    #2275177
    Ying
    Staff
    Customer Support

    Hum…it looks like the site is using Super Page Cache’s cache:
    https://www.screencast.com/t/kbZNkVAQyeA

    #2275185
    Philippe

    That’s Cloudflare Super Page Cache. There is nothing about Javascript in its settings. I am going to check if I could get rid of this plugin entirely.

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.