Black Friday Sale! Get $20 off GP Premium, $40 off our new Lifetime license, and 45% off license renewals/extensions! Learn more

[Resolved] Menu Issue

Home Forums Support Menu Issue

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #62770
    Garth Dryland

    I built a test site http://doublednetworks.co.nz and the menu and pages load fine on all my devices. At this point I only used chrome.

    I moved the site to the production domain using Duplicator plugin to http://accountwise.co.nz and now the pages generally load slower and the drop down menu triangle icons and the search icon tend to disappear between page loads.

    (Please note that these sites are being tested etc so may be offline for short periods however you should be able to see them with a little patience should they be offline when looking)

    I then dropped all browser history along with transient options but the problem continues.

    Any idea on what else I can try?

    I used Chrome, IE and Firefox during testing. i found that the problem tends to be less obvious in IE, but chrome more so and Firefox is not so good, which brings me to a second question.

    Do you know why Firefox would be considerably slower with GP? Other sites seem to load fine.

    #62838
    Tom
    Lead Developer
    Lead Developer

    Hi Garth,

    GP is a super simple theme with very minimal javascript, and all of the functions are derived from core WordPress functions. That’s what makes it fast, lightweight and compatible with all browsers – even old IE versions.

    I just took a look at both sites in Firefox (I develop in Firefox), and they both load the same for me with no issues.

    Some causes could be:

    a) The server you moved it to could be slow in your region
    b) You may have Firefox extensions installed that are slowing down the browser
    c) Your internet/computer may have some issues

    I took a good look around on the site (it looks great btw) – and didn’t notice any speed issues, or any blinking of icons.

    Let me know 🙂

    #62974
    Garth Dryland

    Hi Tom

    Thanks for the compliment and checking into this issue for me!

    I have since installed a copy of the exactly same clone used for creating http://accountwise.co.nz and installed it on another (3rd) domain and it works pretty much perfectly on my computer using chrome IE and Firefox. I haven’t dropped cache or transient options either as I haven’t had the need to try that.

    All of the sites are on the same host with same static IP, so I would next rule out it being http://hostmonster.com who I believe are one of the better (shared environment) hosts out there, especially when it come to wordpress.

    I don’t use extensions on Firefox except Firebug for coding which I gather is why you use it 🙂

    I then tried my wifes computer (at same location on the same IP connection) and the menu jumps around as the icons reload during each page load. I just tested using chrome.

    I’m kind of a little stumped because if you have no issues with http://accountwise.co.nz and I do on two computers, yet I don’t on the other two domains on my computer (but do on my wifes) and I have dropped cache, history, cookies (on my computer), what else could be causing it. It shouldn’t be my internet or the issue should also be constant.

    I am assuming it may somehow still be chrome cache related or the like.

    I am now experiencing the majority of issues with chrome on the site at http://accountwise.co.nz

    All I can think of doing at this stage is (ONE) to try installing the clone again, which feels kind of fruitless and a step backwards given the site works fine for you and me via other browsers or (TWO) check into if others have issues like this with chrome and how they fixed it, if its in fact possible to find such information.

    It seems a bit weird though given chrome works fine on the other two domains like IE and Firefox do with the three sites other than maybe on the first or second page load where the menu can flicker on occasion as the icons reload. Sometimes the header image reloads also on first load.

    I have found that if i change browser and return to another one the header and or menu can reload on occasion.

    The main issue however appears to be when using chrome viewing http://accountwise.co.nz – The other issues are somewhat trivial in comparison. http://accountwise.co.nz reloads the menu (and occasionally the header) practically continuously when using chrome.

    Any further suggestions to offer?

    #62984
    Garth Dryland

    I addition to the above said I also tried setting all menu options to top level and removed the search icon and it appears to load fine on all browsers like that.

    I did this to (ONE) see what happened and (TWO) in a effort to try and create new cache etc and reprogram the settings into the database.

    Upon changing the setting back the problem reoccurs.

    #63015
    Tom
    Lead Developer
    Lead Developer

    Hmm, well there’s always going to be a small jump as the page loads (hardly noticeable), as the arrows and search icon are added via javascript. However, it should almost not be noticeable at all, and definitely shouldn’t continuously load.

    I just checked the site out using Chrome, and didn’t notice anything out of the ordinary – everything loaded fast, and I navigated through the entire site.

    Another possibility might be that the database was corrupted when you transferred the site. Maybe try doing it again? I personally use ImportBuddy to migrate sites – never fails me.

    That being said, if it was database related, I would be experiencing the same issues – which I’m not.

    Sorry I’m not being very helpful – it’s hard to debug stuff when you can’t see the bugs.

    #63080
    Garth Dryland

    Like you I have run into things which really don’t add up. The rule is “consistency is key”.

    I had a promising break through after much testing via numerous devices, browsers and operating systems. I haven’t finished testing yet though. I really can’t say I have narrowed it down just yet but I feel that I am getting a lot closer.

    While the problem isn’t apparent running under many combinations of devices, browsers and operating systems, I have somewhat confirmed that it predominately occurs when using chrome on windows, android tablet and linux using chromium (a linux version of chrome).

    This makes me think chrome potentially uses a different way to cache files than other browsers.

    Perhaps you know something about this given your experience?

    I do however realise that you don’t appear to have an issue with chrome so if I was to apply the rule, the way chrome caches potentially becomes irrelevant.

    Via my phone it seems to be fine under chrome however that browser is somewhat different as it uses the mobile format of GP. You wouldn’t necessarily see the issue, even if it was happening.

    The break through started when I tested the production site via my tablet. While it was an issue under WiFi, it wasn’t using a mobile connection. Immediately I tethered my mobile phone to my windows laptop and the issue seems to be gone. It happens once or twice but I can see the connection is somewhat dead during that instance.

    I will keep testing this issue and tomorrow check using my laptop via a few cafes wifi in the area who I know use a different ISP from me given past testing done for other issues. I will also go and test it on a clients connection who uses the same ISP as me.

    I also know my ISP has removed my server IP from their caching servers recently as it was playing havoc with my wordpress sites. (This is however one of those examples that doesn’t completely add up as being a primary issue or all other browsers etc would show the same problem, including your own) I was getting locked out from my white listed IP. The All In One Security and Firewall Plugin was showing my IP as something other than my own with every page load. (Given the plugin is allegedly only able to display information it receives I approached my ISP). Once my server IP was removed the problem was gone. (The site was also generating ghost users for each new IP. I soon had like 60 uses that I couldn’t log out of. They had to time out)

    I have a couple of question in addition to the one above (ONE) what OS do you use (I assume MAC or Linux) and (TWO) what is your view on the All in One Security and Firewall plugin? I don’t think the previous issue or current one is the fault of said plugin. I’m just curious to know if you have used it and your opinion on it.

    I am planning on using this plugin in conjunction with Sucuri as one pretty much covers what the other doesn’t leaving not to many angles in. I could use the Sucuri firewall instead of All in One but this way its more affordable and potentially eliminates the need for Sucuri for those who don’t want that extra expense. I have been hacked before and its not pretty. LOL

    #64281
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Seeing as I don’t experience any issues on the site in question using Chrome or Firefox, and I haven’t received any other complaints about anything like this (after 100,000+ downloads), I have to assume it has something to do with your local machine/ISP.

    The areas that you say are flashing are using javascript, so maybe it has something to do with your ISP/browser using javascript in a weird way?

    I use Windows (but it doesn’t matter, browsers are browsers).

    Some like to use a Firewall plugin – I personally never have. Simply keeping everything up to date, and using a decent host is all you should need to keep hackers away.

    Let me know if you find anything else out about this issue – and if anyone else reading this thread has a similar issue, definitely let me know.

    Thanks!

    #64535
    Garth Dryland

    It appears that I have solved this issue. It was likely a combination of a few things.

    I believe it was in part due to potentially loosing connection during the clone installation.

    The final time I installed the clone was via 4G mobile connection as my fixed line connection may have played a part. Having said that it works fine using it now.

    The browsers used showed the issue in varying levels, perhaps due to the extensions installed. Browser do however read websites data slightly differently so could be that also.

    It may have also been in part due to the duplicator plugin but I wont be testing that again until I clone another site. It does however appear to create functional clones. I used the same clone through the entire process. Sometimes it wasn’t perfect, now it is.

    This issue was extremely hard to narrow down to a single thing. Impossible even. After some 5000 plus menu clicks while changing various setting etc, it was still very difficult to find what it was.

    I am glad I spent the time to get it back to how I believe it should be, despite others not experiencing the issue.

    If I experience this problem again and manage to narrow it down, I will update this thread.

    PS: My host like my ISP are among some of the biggest players out there. One would hope they get it right most of the time.

    I am glad you haven’t been hacked. Admittedly I did have some out of date Drupal software installed when I was however after doing a fair bit of checking into securing WordPress sites recently, I can see that its likely not only up to date software that will save one from being attacked online. There appears to be numerous ways someone with a hacking background could break into the platform and I feel it would be wise to sort those angles with the above said plugins, or similar.

    #64667
    Tom
    Lead Developer
    Lead Developer

    Awesome, I’m glad you figured it out!

    Definitely a strange problem, but it makes sense that it would be corrupted on transfer – that can definitely happen.

    Let me know if you run into any other problems 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.