[Resolved] Logo settings disappeared from primary navigation

Home Forums Support [Resolved] Logo settings disappeared from primary navigation

Home Forums Support Logo settings disappeared from primary navigation

  • This topic has 3 replies, 2 voices, and was last updated 12 months ago by David.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1496923
    ARML

    Since the 1 or 2 last updates (i’m up to date with generatepress right now), i’m facing an issue. i was customizing mmy child theme from the WP customize feature, editing some settings, when i had a notice “some settings aren’t Ok bla bla bla..” (sorry if i’m not precise, but the message was in my natural language (french).

    I just skipped it and refreshed the page. My logo just disappeared from the primary navigation ! And the settings to select and use and image in the primary navigation menu just disappeared too…. What’s going on ? Probably due to last update (and i’ve never faced the issue with GP before, using it on my 20 websites from my network..).

    So right now, my logo is only showing on mobile views, but not on desktop view, i had to set up a logo in customize => layout => header. I can’t get the logo to show up on deskopt view.
    I tried everything for two last hours, i’m pretty disappointed by this “disappearing” logo settings in primary navigation… help needed !

    Best Regard.

    #1496945
    ARML

    Asa complement, i’ve read this : https://docs.generatepress.com/article/navigation-as-a-header/
    And this topic, wich seems close my experience : https://generatepress.com/forums/topic/sticky-header-width-2/

    So i check the box to use “Navigation as Header” in header settings, but i still facing the issue : mobile views (smartphone and tablet) have the logo, while desktop doesn’t show any logo…

    #1496970
    ARML

    Ha Solved !

    i didn’t read the changelog from last version, but who does ? More than 10 changelogs to read everyday if i read it..
    I suggest a big warning in the documentation.

    With these last updates, you have to define a website logo in website identity… If you dont, and if you are using sticky navigation, the sticky header logo will display, mobile too, but not the desktop one..

    #1497005
    David
    Staff
    Customer Support

    Yes a lot of changes have happened over the last few updates.
    Glad to hear you found the solution.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.