[Resolved] JS Errors in Console – breaking site.

Home Forums Support JS Errors in Console – breaking site.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1350289
    Chelsea

    Aloha,

    Hoping you can be another eye to diagnose the issue with JS errors and broken features.

    FYI: I’m in contact with SearchWP and FacetWP regarding the issue on my dev site… I also have a support request out to BeaverBuilder. Basically here is my set up: I use Generate Press Premium (child’s theme) as my theme and use BeaverBuilder & Ultimate Addon for BeaverBuilder to customize my pages/post.

    I’m building a site that houses lots of wisdom that needs to be user friendly and accessible …. In order to make the site user friendly and generate great search results, I created a page named Teachings on my site to be the Posts Page. Originally I assigned the Teachings page to be the Post Page – basically the “blog” but I found that I wasn’t happy with how the blog page was displaying search results … and I wanted to make the search / filter tools above the post feed vs. in a sidebar. So I removed the Teachings page from being the “blog” and turned the Teachings page back into a regular page to display posts / content feeds via BeaverBuilders Advanced Post Modules so visitors can search for & find various articles, podcasts, etc..and use FacetWP filters to hone in on search results. FYI: SearchWP is also installed on my site and replaces WordPresses native search tool.

    Basically my Teachings page is having fatal errors. The Facets are not showing up. The only thing that shows above the display of posts is a “Reset” button. When I click “Reset” then two of the Facets I created show up. So there seems to be something broken here.

    Additionally and worth noting… in my BeaverBuilder Advanced Post Module (created by Ultimate Addon for BeaverBuilder – which is compatible with FacetWP). When choosing the “Source” under the tab “Query” when I select “Main Query” only one item shows up which is my Teachings page (the same page I’m building my search results page on). This is odd – seems like “Main Query” is broken? – So I’ve been using FacetWP’s template as the query setting – but customizing it with Beaverbuilder module

    Here is what FacetWP shared when they viewed the Teachings page:

    “I also see a number of JS errors in your console – https://d.pr/i/01QVEV – none of these are caused by Facet but are fatal errors that prevent Facet’s JS from running on page load. Once you click the reset button, Facet’s JS is newly triggered and able to complete. You might want to disable your cache temporarily. BB also has a cache you might want to try clearing.”

    Can you please take a look at the page (I added it to my support ticket)

    Curious what your insights might be… I think you all are brilliant so I’m hoping you might have some wisdom to add… Any advise you can provide would be sooo appreciated!

    Thank you!
    Aloha!

    #1350321
    Chelsea

    Just wanted to update my support thread…

    I have been clearing my BeaverBuilder Cache and clearing my cache with my Comet Cache plugin on my site all along… however I took FacetWP’s suggestion and I went ahead and cleared the BeaverBuilder cache and additionally deactivated the Comet Cache plugin. I cleared my browser and now the Facets are showing on my Teachings page! 

    Do you still see the Fatal Errors on the https://rdorgdev.wpengine.com/teachings/ page? 
    Does this fix my issue – besides needing to find a new caching plugin? – FYI: WPEngine is the host for this site and they loaded a cache tool onto the website… maybe this was the conflict? I’d love more of your expert advice on best ways to proceed! 

    Look forward to your thoughts!

    Aloha, 
    Chelsea

    #1350456
    David
    Staff
    Customer Support

    Hi there,

    the only errors i see in the Console are NOTICES stating that Sticky Anything plugin is running in debug mode – so no real errors.

    Caches – we only use Autoptimize for optimization and server side caches.
    All caches require some configuration, so you may want to check with WPEngine as to how best to configure their cache with your requirements.

    #1350915
    Chelsea

    Aloha David,

    Thank you! Does GeneratePress need any specific cache configurations that I should let WPEngine be aware of?

    #1350960
    Chelsea

    FYI: FacetWP plugin just released a plugin update. I ran the update and now my page looks like it is in tablet view when viewing on desktop. It’s also affecting the archive feed / search archive.

    #1351045
    Leo
    Staff
    Customer Support

    Sometimes the combine JS and CSS option (every plugin name them differently) cause some issue.

    Not sure what the issue with FacetWP is – have you tried clearing you caching plugin after the update or check with their support?

    #1351104
    Chelsea

    Aloha Leo,

    I haven’t heard back from FacetWP yet regarding the recent plugin update which has the new error. I did clear WPEngine cache and BeaverBuilder cache but no changes.

    Do have any other ideas?

    #1351114
    Chelsea

    Hi!

    I have a question about “Sticky Menu or Anything” plugin showing some errors. Should I open this up in a new support thread…

    #1351135
    Chelsea

    Updating my thread –

    Debug Mode was set to “on” when I updated the FacetWP plugin this morning. The Changelog for the FacetWP plugin mentioned several updates to Debug Mode. I turned this feature off – and now the site is back to normal size on the problem pages. Yay!

    #1351136
    Chelsea

    Still curious if I can discuss sticky menu or anything error here or open a new thread. thanks!

    #1351215
    Leo
    Staff
    Customer Support

    If you have questions regarding another plugin then it might be best to check with their support team.

    I’ll mark this topic as resolved 🙂

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.