[Support request] Issues with page duplication

Home Forums Support Issues with page duplication

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #1444116
    Real

    Hi,

    I am using the Aspire theme.

    When I duplicate a page (I’ve tried several compatible plugins) the layout gets cluttered.

    How can I fix this?

    Thank you in advance

    #1444138
    Leo
    Staff
    Customer Support

    Hi there,

    Which plugin are you using?

    I’ve used this one before and it works quite nicely:
    https://en-ca.wordpress.org/plugins/duplicate-page/

    Can you link me to the page in question if it doesn’t work?

    #1444196
    Real

    Hi Leo,

    Thanks for your reply.

    In fact, I am using this plugin too, and also I tried other ones.

    Here you have a “broken layout” page: https://profesionalesmallorca.es/calefaccion/

    If you check other inner pages of the site you can see how is supposed to be.

    Thanks

    #1444351
    Leo
    Staff
    Customer Support

    Are you referring to inner pages that are using Elementor?

    If so you will need likely need to check with the plugin support to see if they support Elementor.

    Or check with Elementor’s support to see if they have a recommended method to duplicate a page.

    #1444374
    Real

    Hi,

    Are you referring to inner pages that are using Elementor?

    Yes.

    If so you will need likely need to check with the plugin support to see if they support Elementor.

    With the plugin there is no problem because it worked until 2 days ago and, besides, I have tried others and the same thing happens to me: the layout breaks.

    It is clear that the error comes from the theme and not from a specific plugin.

    #1444376
    Real

    Update:

    I am using this template on other website and also is breaking when I duplicate the page.

    #1444417
    Leo
    Staff
    Customer Support

    With the plugin there is no problem because it worked until 2 days ago

    That sort of shows me that it’s not a theme issue as the theme hasn’t changed in the last 2 days.

    Let’s do some debugging steps anyways.

    – Are you able to activate Elementor on that “broken” page? Right now it’s not activated.

    – If you create a normal page with Gutenberg editor, does the Duplicator plugin works?

    #1444481
    Real

    – Are you able to activate Elementor on that “broken” page? Right now it’s not activated.

    Yes. And I have also removed it and installed it again. And it gives the same error.

    – If you create a normal page with Gutenberg editor, does the Duplicator plugin works?

    Yes, it works.

    And curiously enough, it works (i.e. it doesn’t break the layout) with a sample page with a side sidebar that comes with the theme.

    For each of my internal pages I am using a another sample page that has a central box that overlaps over the header. And this is the one that gives me problems. Note I didn’t create the layout on my own.

    #1444490
    Leo
    Staff
    Customer Support

    – Are you able to activate Elementor on that “broken” page? Right now it’s not activated.

    Yes. And I have also removed it and installed it again. And it gives the same error.

    It just looks like Elementor is not activated on that page. What happens if you click Edit with Elementor on that page?

    – If you create a normal page with Gutenberg editor, does the Duplicator plugin works?

    Yes, it works.

    This really shows that the theme it not the issue as it works with the default editor but not Elementor.

    For each of my internal pages I am using a another sample page that has a central box that overlaps over the header. And this is the one that gives me problems. Note I didn’t create the layout on my own.

    Not sure if I fully understand. So if you create another test page with Elementor, then duplicate it, it works?

    Can you make sure to disable all plugins except GP Premium and Elementor to test?

    We also know that Elementor version 3.0+ are full of bugs so perhaps this is one of them.

    Can you please check with their support to see if they have any ideas? I really doubt that this is a theme issue as the duplicator works with the default Gutenberg editor.

    #1444555
    Real

    With the template came some sample pages with different layouts (services, about us, contact, privacy policy…).

    And I used all of them. I haven’t created any layout on my own.

    The ones with sidebar work by duplicating them and using elementor. The layout is not broken. For example: privacy policy

    (So, Elementor works).

    Those without a sidebar break: services, about us, contact… the layout breaks.

    Besides, I have checked at least 3 sites I have where I am using the same template and in all of them is happening the same. Can be a plugin? Can be…but please consider this message first before I re-install all plugins.

    And by the way, I don’t find the template here anymore: https://generatepress.com/site-library/ Why?

    #1444870
    Elvin
    Customer Support

    Hi,

    I’ve tried replicating this issue with multiple setups.

    Tested this on both GP and Non-GP theme and they yielded the same results. I believe it’s an issue w/ the duplicator plugin itself as duplicating pages on a WP default theme and a GP theme had the same layout issue.

    The ones with sidebar work by duplicating them and using Elementor. The layout is not broken. For example: privacy policy

    Any page duplicated will initially start with a broken layout. However, editing it with Elementor will show a fixed layout but the live page will stay broken unless you apply the fixed page’s layout by pressing the “Update” button on Elementor editor.

    This means the duplicator plugin doesn’t work 100% out of the box.

    Same thing can be done on any other themes.

    And by the way, I don’t find the template here anymore: https://generatepress.com/site-library/ Why?

    It was removed on the latest official release (1.11.3).

    If you want to access it, you can use the alpha version (1.12.0-alpha.1).

    Just deactivate – reactivate the site library module so the list refreshes.

    #1445226
    Real

    Hi Calvin,

    Thank you for your response.

    So the issue is the duplicator. That is, I tried 3 page duplication plugins compatible with the theme and all 3 failed. What a coincidence:

    https://es.wordpress.org/plugins/duplicate-post/
    https://es.wordpress.org/plugins/duplicate-wp-page-post/
    https://es.wordpress.org/plugins/duplicate-page/

    I have the same problem on 8 websites where I am using Aspire Theme. Not all of them use the same duplication plugin or other plugins.

    As I see it is a mystery and there is no solution what I am going to do is change the theme in the 8 sites. More work for me but I need to advance.

    Of course, there is no point in continuing with the subscription with GP.

    Thank you.

    #1445257
    Real

    By the way, just tried the plugin with the template Service and Peak (I have sites using them) and it is working well. No layout issues.

    #1445345
    David
    Staff
    Customer Support

    Hi there,

    Suggestions

    1. Disable any Cache plugins before duplicating.
    2. After duplicating go to Elementor > Tools and Regenerate CSS.

    #1445370
    Real

    Hi David,

    I just tried but no success.

    I also deleted all plugins except:
    Duplicate Page or Post
    Elementor
    GP Premium
    Really Simple SSL

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.