Celebrating 7 Years! Get up to $30 off GeneratePress Premium!

[Support request] Impossible to change the logo

Home Forums Support [Support request] Impossible to change the logo

Home Forums Support Impossible to change the logo

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #600529
    Bernat

    I bought the theme, install it, and upload a logo. All ok,
    Then I upload a new logo image, but all times looks for the first logo image uploaded (in the customize panel I can see the logo correctly uploaded, but when i see the web, there is the old logo.
    The image is correct. If I put the image url in a browser I can see the image without problems. If I put the logo in the content of a page, there is no problem.

    The problem is the theme is looking for the first logo image I add.
    The first logo I add is “logo.png” and the new uploaded in the theme (normal and retina) is “logo-300.png”.
    All time is looking for “logo.png” (I can see this in the html code in browser).

    So, this looks a cache issue, but I clear all cache from server, from cache plugin, unisntall cache plugin, crear Cloudflare, deactivate Cloudflare, contact to host assistence and he verify the cache is clear and this is a theme issue.

    I put the url in GTMetrix and get this:

    The following resources have identical contents, but are served from different URLs. Serve these resources from a consistent URL to save 1 request(s) and 3.5KiB.

    https://#############.com/wp-content/uploads/2018/06/logo-300.png
    https://#############.com/wp-content/uploads/2018/06/logo.png

    thanks a lot

    GeneratePress 2.1.2
    GP Premium 1.6.2
    #600662
    David
    Staff
    Customer Support

    Hi there,

    i can see the correct logo in the Site Logo and Navigation. The old logo is the one in the mobile header. Have you updated this?

    #600716
    Bernat

    This is because I uplicate the new logo and change the file name to get the same look.
    Now I do:
    – Delete logo files uploaded, form ftp
    – Upload a new logo version (in black color) for normal logo, retina logo and mobile logo. All the same image.
    If you see the web in mobile, you can see is looking for the old logo image.
    Thanks!

    #601011
    Leo
    Staff
    Customer Support

    Currently this is still the logo link for the mobile header which is invalid:
    https://urgeles.creactitud.com/wp-content/uploads/2018/06/logo.png

    Are you sure the logo has been re-uploaded here?
    https://docs.generatepress.com/article/mobile-header/

    If so then try disabling WP Rocket and see if it’s a caching issue.

    Let me know 🙂

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.