[Resolved] image error in blog (quite urgent)

Home Forums Support image error in blog (quite urgent)

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1318724
    dasigna

    hi alltogether,

    running a customer site where the gp blog is used for news.
    there, the featured images are set in customizer to use medium size and equal aspect ratio – dimensions set to 600x600px.
    additionally they are set to show rounded as a circle.

    worked great so far until recently – when two of the pictures started to show uneven… now we have two vertically stretched ‘eggs’ on that page which is not very pleasing 🙁

    funny enough, one of them is a fairly old one who showed up correctly til now, the other one is a new one uploaded after last update. so at first i assumed it might have to to with the update somehow. but what about the older one???
    and despite that – all others show up as intended anyway.

    i cant follow neighter the ‘logic’ nor any clear reason for this miracle.

    so i would be glad enough if someone could take a closer look and may come up with any hint or solution.

    many thanks and best wishes.

    #1318930
    David
    Staff
    Customer Support

    Hi there,

    can you go to Customizer > Layout > Blog > Featured Images and re-select your Image attachment size and add the width and height values again and then republish.

    Let me know.

    #1318970
    dasigna

    hi david,

    … yeah – already tried this. including changing the attachment size and dimensions back and forth. in addition tried regenerating thumbnails and constantly clearing cache etc.

    running out of clues.

    credentials added to url – may you can look yourself. but be careful -> its a live site 🙂

    EDIT:
    crazy enough, the lower stretched image is originally one with already even square dimensions …

    #1318982
    David
    Staff
    Customer Support

    Can you disable autoptimize and flush any other caches you may have. So i can take a closer look.

    #1319000
    dasigna

    autoptimize and cache disabled. everything should be cleared.

    #1319005
    David
    Staff
    Customer Support

    Hmmm – thats an odd one…. not sure what WP is doing but its spitting out those images with max-width parameters.

    Perhaps the best solution would be to register a new media attachment size in GP for 600px x 600px cropped.

    https://docs.generatepress.com/article/adding-image-sizes/

    Then simply select that without ant Width / Height values in the customizer:

    This will stop the theme using CSS to resize them.

    #1319087
    dasigna

    _really_ odd!

    registering a new media size and selecting it without size values gives an even worse result – all images are different in ratio …!
    only the odd lower one before (wich has already even image ratio) is correct.

    choosing the customizer dimension in addition gives the same result as before. no healing.

    if its not gp that injects the inline css parameters, theres something completely strange going on …

    #1319092
    dasigna

    UPDATE:
    after another regenerating of thumbnails all featured images are showing as expected – except the already squared one …

    completely weird.

    #1319117
    dasigna

    UPDATE 2:
    works again as expected… stretching of the already even image was obviously due to the fact that it was smaller than the given 600×600 size.
    uploaded a bigger one for it and it is o.k. too.

    but still dont know where this strange behaviour is coming from …

    anyway – big thanks for efforts!

    (maybe let me know if you’ve had some spare time and found out more…)

    #1319119
    David
    Staff
    Customer Support

    Did you change the ‘already squared one’ ? As they all look identical now.

    #1319124
    dasigna

    … see ‘UPDATE 2’ – overlapping posts 🙂

    #1319129
    David
    Staff
    Customer Support

    Awesome – glad to hear its resolved.

    #1319160
    dasigna

    resolved for now, yes.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.