[Resolved] Home page is latest posts but doesn't show up if you click home

Home Forums Support Home page is latest posts but doesn't show up if you click home

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #132329
    Jane

    Hi,

    I have Generate Press with all the add-ons.

    Like other readers and users of Generate Press I am keen to avoid having a sub domain for my blog page. I would also like my blog post to be displayed on my front or home page. I am having some difficulty to make that happen (or permanent) despite trying to follow the posts on the subject in this forum.

    I have my home page set to show my latest posts. When a reader enters the site they go straight to the post, – That is how I want it to be. However if they click elsewhere (or even on home) and then want to come back to the home page -they see nothing.

    I have Settings/Reading/- Front Page displays latest posts

    General Settings urls both WP and site set to euniceparisi-carew.com – if I change these settings to include ….com/home I cannot get into the website. And have to have my host sort the problem out for me. And then I am back where I started.

    Customize – Set Front Page – Front page displays Your latest posts and Front page is home and latest posts page is home. I’ve also tried not setting Front page and leaving posts page as home and vice versa – I still get the same result.

    Please help me I have wasted so much time on trying to fix this myself using YOu tube and your site’s various forums and my host iPage but all has come to the same result nothing in the home page if you click elsehwere.

    #132336
    Jane

    I fixed it by having it set to static page (seemed counter intuitive to me) Home for the posts page.

    #132349
    Tom
    Lead Developer
    Lead Developer

    Hi Jane,

    Sounds like your “Home” menu item was pointing to the wrong page.

    Go to “Appearance > Menus” and choose “Custom Links” on the left.

    Add the URL to your homepage, and add your label (Home).

    That link will always link to your homepage, so you can go ahead and set it to display on the front page and not a static page.

    Let me know if that helps or not 🙂

    #132371
    Lukas

    Hello i will pin to the subject, have same issue.
    Tom i dont quite get your reply. I could only solve it with using menu link as(custom link) and writing the full adress to my site http://www.adlerpneumatyka.pl
    I dont quite get where you want us write home?
    In which form field? “url address”, “navigation label”, “title atribute”, “CSS class”?
    Sorry for noob questions…..

    #132372
    Tom
    Lead Developer
    Lead Developer

    You’d want to write it in “Navigation Label” – this is the label you’ll see in the menu item. You can name it whatever you like, Home is just a suggestion 🙂

    #132429
    Lukas

    So i did ok, link must be to the page and label is optional in my case Aktualnosci (News). Tks !!!

    #132449
    Tom
    Lead Developer
    Lead Developer
    #133355
    Jane

    Hi Tom,

    I have started afresh because I couldn’t get the read more tag or the excerpts on the Blog add-on to work properly. I tried just using the wordpress read more and then I tried using the blog content add-on. In both instances it goes no where and displays nothing.
    I want to have the front page (home) to display excerpts of my blogs and then static pages for about and contact and I will be adding other pages later. When I followed your instructions for the custom link it showed nothing on the home page. I have it set as xxxx.com/home.

    And the display front pages: customise/front page displays latest posts/ Front Page =home page

    When you visit the site it takes you to the front page and then if you click on one of the other pages and return – you get nothing.

    Thanks for your help.

    #133419
    Tom
    Lead Developer
    Lead Developer

    xxxx.com/home isn’t correct if your homepage is set to display posts.

    You would have to go to xxxx.com (no /home).

    Make sure your “Home” menu item points to the homepage (no trailing slash with anything, just xxxx.com).

    That should do it 🙂

    #133526
    Jane

    Hi Tom,

    That fixed the vanishing home page content – I really do appreciate your support. However I still have the problem that the read more tag isn’t working. when I click on the tag it goes to the home page and displays nothing.

    So to recap. My home page is my blog page. The blog has a read more tag and the excerpt box checked. The customize menu,/Set Front Page = Front page displays latest posts and the Front page and posts page are left as select. I have tried using Posts page as home but that doesn’t work.

    can you help me with where the vanishing excerpt has gone?

    Thanks
    Jane

    #133579
    bdbrown

    Hi Jane. Been following this thread and thought I’d see if I can help. Want to make sure I understand your configuration:

    Your posts have content but do not have a manually created excerpt.

    On your menu, the Custom Link for your home page is working, and you have other static pages that are working.

    In Customizer > Blog > Blog Content
    Blog Post Content: Show excerpt
    Excerpt Length: 25 (or whatever length you have)
    Read more label: Read more…
    Other options: show/hide

    Customizer > Set Front Page
    Front page displays: Your latest posts
    Front page and Posts page are not selected

    If that matches your configuration, are you still having problems with the posts on the home page?

    #133604
    Jane

    Hi bdbrown,

    Thank you so much for helping me out.

    I do not have a manually created excerpt.

    I have altered the settings to be exactly as you detail them below. The read more tag works now ( Thank you) and I no longer have a static front page (Thanks you). However if I click on ‘about’ and then click ‘home’tab no content shows up.

    However if I click on recent posts the full article shows up. Then go to the home tab on the menu page still nothing on the home page.

    If I click on the header (title of the website) it takes me to the latest posts page, which is way I would like to happen when people click ‘home’ on the menu.

    Here’s a couple of other settings – I don’t know whether these are helpful:

    Settings/Writing/default post category+ blog
    Default post =standard

    Permalinks: default.

    Thanks again for staying on this for me – I am glad to be making some progress – I had got so disheartened.

    #133659
    bdbrown

    Glad to hear you’re making progress. Based on what you described it sounds like everything is working except the Home menu item. If you edit your menu, the item type for the Home page should be a Custom Link, and the URL should match what is in Settings > Site Address (URL). If those match up the menu should display the Blog home page.

    #133845
    Jane

    HI BD,

    Thank you! Thank you! You are bloody amazing. It’s all fixed.

    Cheers!
    Jane

    #133846
    Tom
    Lead Developer
    Lead Developer

    Thanks for helping, bdbrown! 🙂

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.