[Resolved] GP conflicts with Foogallery

Home Forums Support GP conflicts with Foogallery

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1317016
    Stephen

    Hi guys

    I have a FooGallery on this page:

    https://www.broughtonschoolofmotoring.com/driving-lesson-reviews-testimonials

    It won’t load though. I’ve tweaked a few things, deactivated plugins etc. but nothing worked. Eventually I changed to the default WordPress theme and it loaded ok.

    So I assume the conflict is with GP.

    Dev Toools suggest this file might be the problem: wp-content/themes/generatepress/js/a11y.min.js

    Can you have a look at this for me? Thanks!

    #1317041
    Stephen

    Quick update.

    I use Autoptimize on my site. When I stop optmizing JS, the problem goes away and the gallery loads ok.

    So there seems to be someting, some bit of JS that GP uses that needs to be excluded from being ‘optimized’.

    #1317325
    Leo
    Staff
    Customer Support

    Hi there,

    Have you tried using our suggested settings here?
    https://generatepress.com/fastest-wordpress-theme/

    #1317529
    Stephen

    Thanks for getting back to me so quickly.

    I did change AO’s settings to those in that (very good!) article. But the problem remained. FooGallery wouldn’t load when I was using GP but it did in Twenty Twenty.

    But after a long chat with Frank, the boss over at Autoptimtize (who spent hours working with me on it last night, what a top man he is!) the problem was finally traced back to another plugin, Query Monitor.

    It was changing the paths of two of your JS scripts.

    When Query Monitor was removed, the site worked as expected.

    #1318143
    Leo
    Staff
    Customer Support

    Glad you’ve figured out 🙂

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.