[Resolved] Google PageSpeed

Home Forums Support Google PageSpeed

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1441549
    Bijit Chakraborty

    Hello,
    Don’t know why google page speed showing low matrix on my website.
    I’m using the Autoptimize plugin for caching and shortpixel like premium service for optimizing the images. and it’s not only about google, Pingdom and GTmatrix also showing the same result :/ how can I fix that?

    here is the reference: https://imgur.com/rOCCZUu

    #1441699
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The biggest thing I’m seeing there is your server response time. This could mean your hosting is a bit too slow.

    You could also look at hosting your Google fonts locally with a plugin like this: https://wordpress.org/plugins/host-webfonts-local/

    dashicons.css is loading – are you using these icons on your site? If not, best to find which plugin is adding them so you can remove it.

    jquery.js is loading because you’re using infinite scroll – not much can be done about that one.

    Turning on SVG icons in Customize > General may help a bit as well.

    Ideally, you just want to go through the list of suggestions they provide and tweak whatever you can.

    #1441961
    Bijit Chakraborty

    First of all, thank you so much for your guidance.

    Right now I am using digitalocean’s VPS for my site. I will try to change my server location, maybe It will help because the server load isn’t even 50%.

    dashicons.css: Yeah, I am using Menu Icons by ThemeIsle and I removed it.

    jquery.js: infinite scroll is important for me so, I will leave it.

    Turning on SVG icons: https://imgur.com/XMTqAoV ( you mean to switch the Icon type: Font to SVG?

    Hosting Google fonts locally: I tried that plugin which you mentioned but I guess it is not working properly. I am using a font called Muli for my all menus and somewhere but the plugin doesn’t detect it.

    reference in the private info section.

    #1442204
    David
    Staff
    Customer Support

    Hi there,

    Turning on SVG icons: https://imgur.com/XMTqAoV ( you mean to switch the Icon type: Font to SVG?

    That is correct.

    Hosting Google fonts locally:

    Please make sure you have selected those fonts in Customizer > Typography > Body ( or headings ). Once they are selected in the customizer they will show in the OMGF plugin settings.

    #1442373
    Bijit Chakraborty

    David, I tried but the plugin can’t detect my fonts. ( Georgia, Inherit and other ).
    If you don’t mind can you please check If I shared my login cardinals?

    #1442375
    David
    Staff
    Customer Support

    It will only detect Google fonts.
    Georgia is a system stack font – ie. it is installed on the users device.
    Inherit – is not a Font. It simply means to use whatever font is set on the Body.

    Select a Google font in the customizer and then run the plugin.

    #1442396
    Bijit Chakraborty

    Ahh Got it. It is working now, after selecting specific google fonts in the customizer section. thanks for explaining.

    #1442421
    David
    Staff
    Customer Support
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.