[Resolved] GeneratePress and Gutenberg

Home Forums Support GeneratePress and Gutenberg

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1095752
    a3d-projection

    Hi,

    I went through every recommendation here before I started this thread without success:

    – Clear your browser cache. The same issue is present in all browsers (Safari, Chrome, Firefox)
    – Clear and deactivate any caching plugins. Irrelevant, there are not cache plugins.
    – If you have server caching in place, disable it. Irrelevant, the site was installed in a different server now and the issue still exists.
    – Deactivate your other plugins one by one to check for conflicts. I did and finally I deleted all the plugins in my local environment but still it doesn’t help.
    – Make sure you’re using the latest version of the theme: 2.4.1. I did!
    – Make sure you’re using the latest version of GP Premium: 1.9.1. I did!

    So my question is – how can I disable the function* that controls the display of the titles when I edit a page/post?
    * that disables the display of the titles in 1 click

    I use the latest WordPress 5.3 with Gutenberg and I see the following warnings in the console while trying to edit a post:

    post.php?post=85&action=edit:1 [DOM] Found 2 elements with non-unique id #_wpnonce: (More info: https://goo.gl/9p2vKq) 
    <input type=​"hidden" id=​"_wpnonce" name=​"_wpnonce" value=​"23d590a6f9">​ 
    <input type=​"hidden" id=​"_wpnonce" name=​"_wpnonce" value=​"d9c632c081">​
    
    DevTools failed to parse SourceMap: chrome-extension://gppongmhjkpfnbhagpmjfkannfbllamg/node_modules/webextension-polyfill/dist/browser-polyfill.js.map
    DevTools failed to parse SourceMap: https://aloeveraoriginal.test/wp-includes/js/tinymce/skins/lightgray/skin.min.css.map

    I understand that the option “to disable the display of the titles in 1 click” can be an interesting feature of GP with Gutenberg but if I cannot type anything in the textarea while editing a post seems disappointing to me.

    It must exist an easy way to disable that function. In any case, could you please point me in the right direction to disable that in a child theme? Is there any hook or filter that I don’t aware of despite of my own research?

    Another reflexion is – it’s not clear for me how compatible is GP with Gutenberg, actually. It seems like GP is “Gutenberg Ready” in this page https://generatepress.com/gutenberg/ but later when I look at the documentation, I read the following message: “Please note that Sections cannot be used with Gutenberg editor currently.”

    Perhaps it’s all about the sections module, strangely enough is that I also tested to disable the sections module to see if something changes, but not.

    Thank you in advance for any light in this topic.

    #1095921
    David
    Staff
    Customer Support

    Hi there,

    those console errors don’t look like they are related to the Show / Hide Title function of GP and that function would not impact your ability to edit the content.

    Can you try a different browser? If that resolves the issue then the problem may be related to Browser extensions.

    The GP Theme is Gutenberg Ready – The sections Module is part of the GP Premium Plugin, consider it a simple pagebuilder and like any pagebuilder plugin provides a separate interface over the traditional WP editor.

    #1095979
    a3d-projection

    Hi David,

    Thank you for your answer. As I said before, the same issue is present in every browser: Safari, Chrome and Firefox.

    So back to my question please – how can I disable the function* that controls the display of the titles when I edit a page/post? I don’t see a need for that option at all.

    I also understand what you say about the sections module, unfortunately the issue is present in every page or post I try to edit.

    #1096589
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Is there any way you can post a screenshot or a video of the issue? That option to remove the title on the frontend shouldn’t affect your ability to edit the title at all – sounds like something weird is going on.

    Sections were introduced way before Gutenberg (or page builder plugins). The foundation of it can’t exist in Gutenberg, but Gutenberg itself is actually a cool replacement for it. The two can’t work together, unfortunately. Everything else in GP is 100% compatible with Gutenberg.

    Let me know about the title issue – I’ve made a note to make it easier to disable that option in Gutenberg, as right now it’s not super easy.

    #1096810
    a3d-projection

    Thank you Tom!

    I agree with you that something weird is going on. I believe it must be something with the script that controls the <button class="content-title-visibility disable-content-title" title="Disable Content Title" aria-hidden="true"></button> and the <textarea id="post-title-0" class="editor-post-title__input" placeholder="Lägg till rubrik" rows="1" style="overflow: hidden; overflow-wrap: break-word; resize: none; height: 40px;">Aloe Vera composition</textarea>

    Here you have a screenshot that perhaps shows what I mean:
    https://drive.google.com/file/d/1M_qJnFTSmCpuXjiCRBl26xzj4ieoxyOW/view?usp=sharing

    And some other warnings:

    load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3:4 [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
    send @ load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils&ver=5.3:4
    DevTools failed to parse SourceMap: https://aloeveraoriginal.se/wp-content/plugins/gp-premium/sections/functions/metaboxes/css/meta.css.map
    DevTools failed to parse SourceMap: https://aloeveraoriginal.se/wp-includes/js/tinymce/skins/lightgray/skin.min.css.map
    #1097166
    Tom
    Lead Developer
    Lead Developer

    Is this something you can reproduce on any of your other sites?

    Where is that red <textarea... text coming from? Is that in the editor or added in the screenshot?

    Is your Heading 1 font size set to something other than 0 in Customize > Typography?

    #1098499
    a3d-projection

    Dear Tom,

    The red <textarea... text was added in the screenshot, pointing to the input field that I thought was related to the issue.

    Concerning the “Heading 1 font size” in Customize > Typography, you are right – it was set to 0. I changed it and now the issue is gone. Great!

    I appreciate your professional advice and quick response. Thank you!

    Henry

    #1098965
    Tom
    Lead Developer
    Lead Developer
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.