[Resolved] Full Width Option

Home Forums Support [Resolved] Full Width Option

Home Forums Support Full Width Option

  • This topic has 17 replies, 4 voices, and was last updated 1 month ago by Elvin.
Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #2047102
    Laurie

    Hello,
    I have just started to put together another site and wish to set the default to “Full width” (and then define the margins/ padding), in Appearance/Customise/Layout/Container I do not have the option to set the default to “Full Width”, the only options are “One Container” and “Separate Containers”. I thought there was a setting there to set to “full width”.

    Thank you for your help.

    L

    #2047192
    Elvin
    Staff
    Customer Support

    Hi Laurie,

    You can set it up through a Layout Element – https://docs.generatepress.com/article/layout-element-overview/

    The option specifically is on the Content tab –
    https://docs.generatepress.com/article/layout-element-overview/#content-1

    You then set the display rule location to the post or pages you want to apply this on.

    Note: The contents may not go full width if you’re using any blocks (ex: GenerateBlocks’ Container Block) that is setting a specific max-width limit. πŸ˜€

    A wise man once said:
    "Have you cleared your cache?"

    #2047221
    Laurie

    Hello, Thank you for your help, I was aware that this could be set when editing a page, but thought that it could be set within the “customise” panel?

    I have added an element that addresses the content but the header is still the width of the container (which I do not want), I would like the header to be “full width” as well (and add padding to desktop, tablet mobile as required).

    Why do I think this used to be able to be all done within the customise panel??

    Many thanks

    #2047374
    David
    Staff
    Customer Support

    Hi there,

    Theres never bee a full width option for the Customizer > Layout > Container. You can fake it though by entering a ridiculously hight value like 10000 in the Width field.

    #2048235
    Laurie

    Hello,
    Thank you for your response, I have added the element to enable the content to be “Full Width” which sets the default content for the site to full width, I noticed that the Site title in the header was not full width, (aligning to the left as per the content). I searched online for a solution and found the following (https://docs.generatepress.com/article/header-layout/) that states that if you set the “inner” header width to “Full Width” then the site title should align to the left full width of the screen, for some reason it does not seem to want to do this, I have checked and cannot see any css or anything that could possibly stop this from working, I am obviously doing something wrong, could you please advise, thank you

    #2048242
    Elvin
    Staff
    Customer Support

    That setting is still the correct one.

    You set it up like this for it to go full width – https://share.getcloudapp.com/BluDrGZy

    I’ve checked the page and it doesn’t seem to be applied. Can you check again and confirm it it was published when you made the change?

    Let us know. πŸ˜€

    A wise man once said:
    "Have you cleared your cache?"

    #2048268
    Laurie

    Hello, I have checked and the settings seem to be as directed, I have attached the images of the “settings” and the “viewed Page” (saved and published), as you can see, the “Near Me site Title does not seem to be aligning left?

    Image 1

    Image 2

    thank you again for your help

    #2048276
    Elvin
    Staff
    Customer Support

    Can you try temporarily disabling ALL plugins except GP Premium and check again? (to eliminate potential plugin conflicts)

    If you have CDN or page caching on the hosting’s CPanel, can you try clearing them up as well?

    A wise man once said:
    "Have you cleared your cache?"

    #2048285
    Laurie

    I have disabled all plugins except GP, problem persists, please see attached image;

    https://near-me.org.uk/wp-content/uploads/2021/12/page-as-viewed-2.png

    Many thanks

    #2048321
    Elvin
    Staff
    Customer Support

    Strange,

    Can you provide us temporary backend access to check things?

    You can use the private information text field to provide the details – https://docs.generatepress.com/article/using-the-premium-support-forum/#private-information

    A wise man once said:
    "Have you cleared your cache?"

    #2048349
    Laurie

    Hello,
    Please see the required information;

    Thank you

    #2048594
    David
    Staff
    Customer Support

    In the Customizer > Layout > Header you have 10px of left and right padding which is whats affecting the alignment. If you want the Site Title / Tag line to touch the edge of the viewport then set that padding to 0

    #2048615
    Laurie

    Hello, I have set the margins to 0 as suggested, it is still the same, the site title is not aligned as expected?

    #2049227
    Ying
    Staff
    Customer Support

    Hi Laurie,

    When I logged in, I can see that padding is gone, but on frontend it still has paddings.

    It’s likely a cache issue, can you disable all cache plugins( if you are using one) and check if you have server cache enabled?

    Let me know πŸ™‚

    #2049456
    Laurie

    Hello,
    Thank you for getting back to me, I do not have any cache plugins enabled, I have cleared the cache and the problem persists?

    This is getting very frustrating?

Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.