[Support request] full posts showing instead of excerpts

Home Forums Support full posts showing instead of excerpts

  • This topic has 14 replies, 3 voices, and was last updated 1 month ago by Leo.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #641809
    BeeLady11

    Hi
    I’m probably missing something right under my nose here….

    I am migrating a client from WP.com to WP.org, using GeneratePress as the theme. The past posts have come over nicely.

    The client tends to type in REALLY long posts. I would like each post on the home page to automatically be shown as a shortened version (whether she’s typed in an excerpt on not for a particular post), so a user clicks on a ‘Read More’ button to open the single post view to keep reading.

    I’ve gone to Customise-Layout-Blog and ensured that Content type is ‘Excerpt’. Word count is 55 for now.

    No matter what I change, I still get the entire posts on the home page.

    Any suggestions?

    Tx
    A

    GeneratePress 2.1.3
    GP Premium 1.6.2
    #641822
    Leo
    Staff
    Customer Support

    Hi there,

    Are you using the more tag?
    https://docs.generatepress.com/article/using-the-more-tag/

    By default WordPress strips all HTML in excerpt (links, pictures etc) unless you are using the more tag.

    Let me know 🙂

    #641826
    BeeLady11

    Hi Leo – great response time!

    I have put in the ‘more’ tags on the more recent posts, which has done the trick, thanks. What would be perfect though is for the posts to automatically truncate when displayed on the homepage, without the client having to remember to put the tag in. Is this possible?

    Thanks

    #641839
    Leo
    Staff
    Customer Support

    If you want the customizer excerpt option to apply then you cannot use the more tag.

    Let me know if this makes sense.

    #641844
    BeeLady11

    Hi Leo – yes, that was why I didn’t originally put the ‘more’ tags in.

    So – if I take the ‘more’ tags out of the posts, how do I get the automatic excerpt option to work? It didn’t before.

    Thanks

    #641850
    Leo
    Staff
    Customer Support

    It should work.

    You need to make sure there isn’t the more tag inserted at the end of the posts for those old posts.

    Also try clearing your caching plugins.

    #641858
    BeeLady11

    `Hi

    Right, I’ve been through all the posts I’ve just inserted ‘More’ tags into and removed them all and purged everything in sight.
    Back to square 1 – massive posts showing in full.
    Any chance you could look at it and see if there’s anything I need to do to make this work?

    The first post on the home page is a sticky post and can be ignored.

    Thanks

    #641871
    BeeLady11

    ps I followed the instructions pointed to in this post: https://generatepress.com/forums/topic/blog-excerpt-length-not-working/ (glad I’m not the only one!) and deactivated all my plugins except generatepress etc. No difference and when I reactivated them, still no difference …

    #641873
    Leo
    Staff
    Customer Support

    Hmm can you test by creating a new post with some random content and don’t use the more tag, does the customizer option apply?

    #641878
    BeeLady11

    Hi – done that. Tried it without an excerpt, then with and it made no difference.
    It’s the first post (after the ‘sticky’ post) and shows in full …

    #641880
    Leo
    Staff
    Customer Support

    And the customizer option is set to show excerpt?

    If so then try #1 here:
    https://docs.generatepress.com/article/debugging-tips/

    We haven’t had this reported before so let’s eliminate other plugins conflicts first.

    #641892
    BeeLady11

    Hi – if you look at https://generatepress.com/forums/topic/full-posts-showing-instead-of-excerpts/#post-641871 – I have already done all that!
    In fact debug mode is still on.

    A

    #641898
    Leo
    Staff
    Customer Support

    Looks like all of them indicated that there was some sort of plugin conflicts.

    Can you disable all them except GP and let me have a look?

    If that doesn’t work then can you leave the plugin disabled and send me the admin info through Account Issue here?
    https://generatepress.com/contact/

    #1310565
    Oniel

    Hi, if you have not solved this problem as yet, here is how I have fixed mine.

    Under Status & Visibility, check if your Post Format is set to Standard. If not, then click the dropdown menu and select standard and it should do the job for you. I hope this helps. God Bless.

    #1310570
    Leo
    Staff
    Customer Support
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.