[Support request] Display error

Home Forums Support Display error

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1446555
    Cody

    Hello,

    (1) question 1:
    When the posts (for example: article “Helllo World”) display in the homepage. The “Featured image” on the right position. But visit the posts (for example: article”Helllo World”), it displays over the title. it’s wrong. It should display below the title. How to solve it?

    (2) question 2:
    The “table of content” navigation should not appear here, it should only appear in the article content. How to solve it?

    Please check the attachments (images: 1.png, 2.png).
    https://ibb.co/LgrY4Dk (or https://freeimage.host/i/2okJXp)
    https://ibb.co/278cz7F (or https://freeimage.host/i/2okHIR)

    Looking forward to your reply.
    Thanks in advance.

    Best wishes,
    Jessy

    #1446564
    Elvin
    Customer Support

    Hi Jessy,

    Can you provide us a link to your site so we could take a closer look? It’ll give us an idea as to why it’s happening.

    Meanwhile, we can check if:

    1.) Perhaps you have a GP Header Element or Hook Element that does this. You may want to change its display rules or completely remove them so doesn’t happen.

    2.) We’ll need to check the site to get clues as there are plenty of possible reasons why it appears there.
    Ex: GP Hook element, shortcode added to content, 3rd party plugin that hooks it before content, etc.

    You can add your site details to the Private Information field. 🙂

    #1446827
    Cody

    Hi,
    The login address of the WordPress backend is as follows, you can access directly, automatically log in, no account password is required.

    #1447404
    Leo
    Staff
    Customer Support

    1. Have you tried changing the featured image location for Posts here?
    https://docs.generatepress.com/article/adjusting-the-featured-images/

    2. How is that table of content added? The login you’ve provided only allows limited access so we can’t see what element you’ve created etc.

    #1447954
    Cody

    Hi Leo,

    You can edit and view directly. It’s just a “table of content” content navigation. It should not appear in the blog archives.
    Please see the attachment (01.png, 02.png).

    Looking forward to your reply.
    Thanks in advance.
    Cody

    #1447962
    Leo
    Staff
    Customer Support

    Hmm that’s using Thrive so it’s something you will need to report it to their support.

    GP uses the default the_excerpt() function in WordPress:
    https://developer.wordpress.org/reference/functions/the_excerpt/

    So Thrive needs to have a way to ignore that in excerpt.

    Another option would be to use the custom excerpt metabox to overwrite the default word count excerpt:
    https://www.wpbeginner.com/plugins/how-to-customize-wordpress-excerpts-no-coding-required/

    Also are you using Thrive for anything else? If it’s just for table of content then it might be good to consider just using this plugin:
    https://wordpress.org/plugins/easy-table-of-contents/

    #1447974
    Cody

    Hi Leo,

    Thanks for your reply.

    #1447979
    Leo
    Staff
    Customer Support

    There is no code that we can use to skip that unfortunately – this is not a theme issue and you should see the exact same thing when using a twenty series default WP theme.

    I would recommend checking with Thrive’s support as this is likely something they need to fix.

    Or use one of the two alternatives I suggested in the previous reply.

    #1449672
    Longinos

    Sorry for spaming this.
    If I´m not wrong, by default wordpress take the 1st X word from the_content() to fill the excerpt, if these X 1st words have a shortcode, this is showed. To avoid this, fill the excerpt metabox in the post.

    #1450189
    Leo
    Staff
    Customer Support
Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.