[Resolved] Click twice on mobile links

Home Forums Support [Resolved] Click twice on mobile links

Home Forums Support Click twice on mobile links

Viewing 15 posts - 16 through 30 (of 33 total)
  • Author
    Posts
  • #1647494
    David
    Staff
    Customer Support

    Hi there,

    i am not that aware of all the WP Rocket settings, but this generally occurs if JS is being deferred. Otherwise, you can debug by temporarily disable each setting one at a time to check whats the issue.

    #1882017
    Simon

    HI, i was having this problem and once i deactivated the Back to Top Button the problem was gone. (I was having the problem only on iOS)

    #1883191
    David
    Staff
    Customer Support

    Hi Simon,

    did you have the issue on a specific device ? As i cannot replicate the problem locally.

    #1883244
    Simon

    Hi David,

    Problem with the iPhone & iPad Safari latest os version with WPRocket ver 3.8.8

    How i found it
    I deactivated all plugins and there was no problem, then reactivate them still have the problem, I reset all the settings of Generate Press Pro, and the problem was gone, so I added all the settings almost one by one using json import, and test, and once I added the top of the page I started having the problem, so i tested right a way online by deactivating the top of the page and the problem was gone …

    How i debug it:
    – Export the GPPro Setting json (Only Generate Press Pro version can export the settings)
    – Modify the json
    – Import the json + Empty WPRocket Cache + Browser Cache + Reload . Test and repeat.

    I debugged on my local computer using MAMP and MAMP iOS app to see the site …

    1- Export GPPro original Setting and backup the json file
    2- Reset the GPPro setting
    3- Test the site, to check if the problem persist
    IF No
    4- Edit the original json file and remove some / many blocks, for example :
    Before
    “options”: {
    “generate_settings”: {
    “smooth_scroll”: true,
    “nav_search”: “enable”,
    “link_color”: “#298e0c”,
    ….
    }
    After
    “options”: {
    “generate_settings”: {}

    5- Import the json
    6- Delete the WP Rocket Cache (i did by deleting the files)
    7- go on the a website page with my desktop browser and test – WP Rocket Create Cache
    8- After Try with iPhone
    — If the problem isn’t there repeat number 4 adding new settings and repeat.

    And finally when i added the top of the page the problem appear.

    During all my research, I found that everyone faced different problems and found different solutions (https://github.com/wp-media/wp-rocket/issues/3142).

    For the solution was this

    #1883402
    David
    Staff
    Customer Support

    So this issue only arises when the WP Rocket defer JS option is enabled ?

    #1883405
    Simon

    Yes this issue only arises when the WP Rocket defer JS option is enabled

    #1883499
    David
    Staff
    Customer Support

    Looking at that Github issue the ‘bug’ fix has been added to the WP Rocket wishlist and is planned for next release. I hope that is the case as it seems to be major issue, and not just for users of GP.

    #2170320
    plo1

    Hello! I’m getting this same issue (or very similar) but only on Chrome mobile on iOS devices (have not tested on android devices). Everything seems to work fine on Safari browser.

    I removed every plugin on my website except GP Premium and the issue remained. As soon as I deactivated GP Premium the issue was no longer there.

    Just to clarify the problem:
    1. Every link within the body of the page (text, buttons, images) requires two clicks initially after the page loads for the first time.
    2. The first click changes the color of the link/button. Any subsequent click will work normally.
    3. I removed WPRocket completely and the issue still remained.
    4. WordPress and all plugins are up to date.

    Looking forward to your feedback!

    #2170360
    Ying
    Staff
    Customer Support

    Hi Paulo,

    As soon as I deactivated GP Premium the issue was no longer there.

    Can you re-activate GP premium then go to appearance > GenretaPress, disable all modules?

    Then activate the modules one at a time to test which one is causing the issue.

    Let me know!

    #2170390
    plo1

    Thanks for the reply! I deactivated all modules and the issue is still present.

    #2170401
    Ying
    Staff
    Customer Support

    Disabling all modules is the same as disabling GP premium plugin, if disable GP premium plugin works, then disable all premium modules should’ve worked as well.

    Can you make sure all cache is cleared?

    If so, I highly doubt it’s a GP premium issue.

    #2170504
    plo1

    Hello again 🙂 I repeated both procedures (deactivating the modules and the plugin) and ensured to clear the cache each time. In both cases the issue appeared to still be present so I’m guessing this isn’t a GP Premium issue.
    Thanks for the support.

    #2170527
    Simon

    Hi @Paulo, did you try to deactivate the same thing as i did ?
    – Disable GP Top of the Page feature

    #2171432
    Ying
    Staff
    Customer Support

    Hi Paulo,

    There’s one more thing to try is to disable GP theme, switch to a twenty twenty series theme to ensure it’s an issue of GP theme 🙂

    Let me know!

    #2171586
    plo1

    Hi @Simon, I don’t have that feature enabled.

Viewing 15 posts - 16 through 30 (of 33 total)
  • You must be logged in to reply to this topic.