[Resolved] Click twice on mobile links

Home Forums Support [Resolved] Click twice on mobile links

Home Forums Support Click twice on mobile links

  • This topic has 32 replies, 7 voices, and was last updated 3 months ago by plo1.
Viewing 15 posts - 1 through 15 (of 33 total)
  • Author
    Posts
  • #1589954
    Rebeca

    Hi,

    I have a problem on my GP site on mobile. I have to ckick twice on any link on mobile. When I touch once, the link don´t work. I have to press the links on the mobile site two times to open. It seems to happen only on ios.

    I already disable all plugins except GP premium but nothing occurs. It is still happening this big problem.

    I don´t use Flying Scripts.

    #1590072
    Leo
    Staff
    Customer Support

    Hi there,

    Which links are you referring to?

    I just tested the menu items links and those seem to be working perfectly for me.

    If you are referring to links added with Elementor, can you check with the plugin support first?

    Let me know 🙂

    #1590215
    Rebeca

    Hi,

    I refer about every single link added on my website (not menu links and not breadcrumbs links but It happens on content links likes pages, post, footer, sidebar…everything) on elementor pages and not elementor pages.

    I already disable elementor and that´s not the problem.

    #1590388
    David
    Staff
    Customer Support

    Hi there,

    i notice that i have to click the Cookie Notice a couple of times for it to remove the notice. After that all of the links in any of the page content works first time.

    Does the issue persist after you successfully follow a link?

    #1590529
    Rebeca

    Hi thanks for your answer but it´s still not working. I´m going to explain it again.

    On mobile (it seems to happen only on ios) you have to press links two times to go to another page (internal or external). When you click the Cookie notice (twice) the other links will work fine, but when you go to another page the problem starts again. It´s always the same thing. To navigate through the pages and posts you always have to click twice. The only links that work properly are menu links and breadcrumbs.

    I try to disable all plugins (elementor included) and the issue persists. I try another theme with the same plugins and the issue disappears. I’ve been trying all kinds of solutions for the last few days and I can´t fix it. The problem is Generate Press but I can´t resolve it without your help. What can I do?

    #1590552
    David
    Staff
    Customer Support

    I can see a script on your site that is ‘doing something’ to the default link behaviour. Can you disable your cache plugin so i can see what is adding that script ?

    #1590554
    Rebeca

    Done. I´ve just disable wp rocket and varnish cache. I’m waiting for (good) news.

    #1590794
    David
    Staff
    Customer Support

    I am still seeing a cached JS file – can you check that all caches are disabled ?

    #1590924
    Rebeca

    Is it ok now? I disable one more time both cache plugins

    #1591026
    David
    Staff
    Customer Support

    I am still seeing a cached JS – one thing can you try disabling the cookie notice in case thats blocking the links.

    #1591085
    Rebeca

    Got it. I think the problem It´s WP Rocket. Did you know of any incompatibility with this plugin?

    #1591194
    David
    Staff
    Customer Support

    Theres no incompatibility – it will be one of the WP Rocket settings. Probably one that is deferring the loading of Javascript. Not sure but try disabling this feature:

    https://docs.wp-rocket.me/article/1265-load-javascript-deferred

    #1591337
    Rebeca

    That´s right. The problem was the javascript settings on Wp rocket.

    Thanks a lot

    #1591651
    David
    Staff
    Customer Support

    Awesome – glad you found the issue!

    #1647262
    Kumar

    Hi there,

    I have the same issue – do you know which script was it? So that I can exclude the defer option for this javascript.

    Thanks
    K

Viewing 15 posts - 1 through 15 (of 33 total)
  • You must be logged in to reply to this topic.