Black Friday Sale! Get up to $30 off GP Premium! Learn more ➝

Add-ons installed successfully but NOT showing in Customise

Home Forums Support Add-ons installed successfully but NOT showing in Customise

Home Forums Support Add-ons installed successfully but NOT showing in Customise

  • This topic has 15 replies, 6 voices, and was last updated 4 years ago by Leo.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #208648
    Patricia

    Hello,

    I have successfully purchased and uploaded onto my WP website through the Plugins section 4 add-ons.

    Generate Menu Plus –

    Generate Sections –

    Generate Disable Elements –

    Generate Spacing –

    and I have successfully updated with the correspondent licence keys.

    However, the “Generate Sections” works.

    “Disable Elements” “Generate Spacing” “Generate Menu Plus” neither of them work.

    Please I need to know how to make them work?

    Thank you

    #208660
    Patricia

    I have contacted my Hosting company after reading this:
    License Won’t Activate
    So you’ve installed your add-on, and now you’re trying to activate your license so you can receive automatic updates.

    You add your license key to the field, and click the “Update” button, but your license key doesn’t activate.

    This can happen when your hosting isn’t allowing external communication with other web servers.

    To fix this issue, please contact your host and ask them to allow your WordPress installation to communicate with https://generatepress.com using the wp_remote_post function.

    They may have to turn PHP cURL on.

    They’ve answered this:

    Danny: (12:56): I can confirm that cURL is turned on and the external connections are allowed on our side.
    Danny: (12:57): Please let the developers know that we do not block the connections to further check this issue.

    So, I need your help with this issue please. Thank you

    #208752
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    The Customizer was re-organized two days ago – I need to re-do the videos today.

    Check out these pages for instructions on how to find the options.

    Spacing: https://generatepress.com/knowledgebase/generate-spacing/
    Menu Plus: https://generatepress.com/knowledgebase/generate-menu-plus/
    Disable Elements: https://generatepress.com/knowledgebase/disable-elements/

    Let me know if you need more info 🙂

    #209220
    Chris

    Hi Tom,

    I’m having a similar issue. I’m using GP (as a child theme) with all the add-ons installed and activated and the license key activated too.

    However, none are appearing in the customiser. This isn’t an issue with other similar sites on the same server.

    Any ideas?

    Thanks,

    Chris

    #209251
    Mizanur

    Hi Tom,

    After the update, I can see ‘copyright’ moved to Customizer, but MenuPlus, Blog, Blog Page Header, Element Spacing missing there.
    All 13 add-ons are activated.
    Thanks
    Mizan
    GP 1.3.33
    GP Premium 1.2.87

    View post on imgur.com

    #209301
    Tom
    Lead Developer
    Lead Developer

    The Customizer has been re-organized.

    Check out this post for details on where settings ended up: https://generatepress.com/gp-premium-1-2-87/

    #209319
    Chris

    Hi Tom,

    I appreciate that the customizer has been reorganised, but I think this issue is related to something else.

    Despite having all the add-ons installed and activated and the license key reactivated, these are the only options now available in the customizer:

    Customizer

    Also, when I attempt to export the settings of the premium add-ons, the JSON file just contains the word “false”.

    Surely something is amiss?

    Chris

    #209329
    Tom
    Lead Developer
    Lead Developer

    When you open the “Layout” panel, you’ll find more options.

    For example, if the Secondary Navigation add-on is activated, those options can be found:

    • Layout / Secondary Navigation
    • Colors / Secondary Navigation
    • Colors / Secondary Sub-Navigation
    • Typography / Secondary Navigation
    • Background Images / Secondary Navigation
    • Background Images / Secondary Sub-Navigation

    Basically, all colors are found in the Colors panel, Typography in the typography panel etc..

    Most of the options (spacing etc..) were moved into the Layout panel inside their respective sections.

    #209384
    Chris

    Thanks for the prompt reply Tom. So where will I now find the setting to show/hide the author on the blog post, which was previously found here: Blog > Blog Content > Author (show/hide)?

    Chris

    #209387
    Tom
    Lead Developer
    Lead Developer

    It hasn’t moved, but you need to be viewing the blog inside the customizer in order to see those blog specific options 🙂

    #209511
    Chris

    Thanks Tom. That completely solved the problem. My apologies if I missed the explanation of that change in the documentation.

    Chris

    #209620
    Tom
    Lead Developer
    Lead Developer

    No problem at all! Glad it’s all working 🙂

    #435221
    Amol Chavan

    Hello Tom,

    I have recently purchased the GP premium 1.5.5, but I am unable to see all the option while customising like Menu plus, Copyright.

    Also I have activated all the add-ons but WooCommernce still showing disabled and deactivated? Why ?

    Do I need to delete the customizer setting using “Appearance > GeneratePress” and click the “Delete Customizer Settings” buttons.
    Pls help.

    #435261
    Leo
    Staff
    Customer Support

    Hi Amol,

    Can you check out this article first? https://docs.generatepress.com/article/installing-gp-premium/#activate-your-add-ons

    Our documentation page should show you where every feature is if you search the keyword: https://docs.generatepress.com/

    If this doesn’t help, can you start a topic for your question?

    Thanks!

    #437613
    Amol Chavan

    Also I have activated all the add-ons but WooCommernce still showing disabled and deactivated? Why ?

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.