[Resolved] 1.2.8.4: New problems with page header

Home Forums Support [Resolved] 1.2.8.4: New problems with page header

Home Forums Support 1.2.8.4: New problems with page header

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #196346
    Daniel

    Hello Tom,

    two versions ago on my multisite everything with the page header worked fine. Since 1.2.82 I have lot of trouble. Image cropping does not work anymore.

    Since todays update it does not take effect on width and height. And curiously all pageheader images in my subsites seem to be cached from wordpress.com? Only the pageheader images, no other images on the site!

    The URL looks something like: http://i1.wp.com/unser-quartier.de/mysubsite/files/it should be http://unser-quartier.de/mysubsite/files/

    Have a look here: http://unser-quartier.de/neue-mitte

    I have definitely no Jetpack Photon or any other CDN activated.

    Any idea?

    Best wishes

    Daniel

    • This topic was modified 5 years, 2 months ago by Daniel.
    #196376
    Paul

    Hi Tom

    got the same problem here. If page header image crop mode is activated, strange image size formats appear. If crop mode is deactivated, the original image size is used/shown.

    Please advice,
    Best regards, Paul

    • This reply was modified 5 years, 2 months ago by Paul.
    #196381
    Sean

    Did you have Photon on previously? I believe the URL is a feature of Photon. May need to take extra steps to get your media back to your website directly. I currently use it though, works very well.

    #196412
    Paul

    Hi Sean

    I just realised the not working crop function. I don’t have any jetpack add ons like photon activated

    Paul

    #196417
    xdaniel

    Maybe I had photon. But I can reproduce it on several subsites in my network and even when I upload a new image. (this is also my account on another job).

    #196424
    Tom
    Lead Developer
    Lead Developer

    A URL like this is because of Photon/the automattic CDN: http://i1.wp.com/...

    Finding an image resizer that works for everyone has proven to be ridiculously difficult.

    Can you all link me to pages where the crop function isn’t working?

    #196427
    Paul

    Hi Tom

    this is my website: http://www.gronova.org/ where i have different page header images and parameters: crop , width 1200px, height: 200px set, but not working as expected. Don’t know since when, but updated generatepress add ons this morning.

    Thx a lot in advance, Paul

    #196430
    Tom
    Lead Developer
    Lead Developer

    It looks like you’re using Photon as well.

    This issue seems to be associated with Photon, which doesn’t allow for cropping, it will just resize the image proportionally.

    #196434
    Paul

    sorry Tom, but photon (jetpack) isn’t activated here.
    any idea where/what to check else?, Paul

    #196437
    xdaniel

    hello Tom, same here: http://unser-quartier.de/neue-mitte

    Definitely no photon activated and same happens when I upload new images.
    Image on the site should be cropped to 1100×200

    #196441
    Tom
    Lead Developer
    Lead Developer

    The URLs both of your sites are using are from WordPress.com (Photon).

    Here’s a snippet of the function that serves the images:

    if( function_exists( 'jetpack_photon_url' ) ) {
    	$args = array( 'fit' => $width . ',' . $height );
    	return jetpack_photon_url( $url, $args );
    }

    So for both of you, the jetpack_photon_url() function exists.

    I’ll see if I can get Jetpack to crop and not just resize, but you should both look into why this function exists on your site if Photon isn’t activated.

    #196447
    xdaniel

    But why is it the only image on the site is served by photon? no other image is from this source and the problem happens first in 1.2.8.2?

    I’ll deactivate jetpack completely for a moment and see what happens.

    #196449
    Tom
    Lead Developer
    Lead Developer

    1.2.82 switched to a new image resizer as the one below was causing issues.

    The one from 1.2.82 was causing more issues, so we just switched to a new one which I like way more (way lighter).

    So that’s why these image issues have popped up since 1.2.82.

    I just wrote a fix for the resizer when Photon is in use if you want to try it out. If so, let me know at support@generatepress.com 🙂

    #196453
    xdaniel

    Hi Tom, yes you can send it to me.

    Here’s another site on a completely different environment with the same problem. No photon activated: http://kulturmanagement-online.de/
    I did not change anything after update yet. On this site it worked with 1.2.83 Only the page header is served by i0.wp.com

    #196455
    Tom
    Lead Developer
    Lead Developer

    Cool, shoot me an email so I know what email to send it to.

    If it’s being served through i0.wp.com, it means the jetpack_photon_url() function exists somewhere on the site. It couldn’t be served through that address if it didn’t (GP can’t use that address even if it wanted to).

Viewing 15 posts - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.