[Support request] YouTube Videos not embedding

Home Forums Support YouTube Videos not embedding

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1343893
    Downtown Spanish

    Hello,

    I can’t embed any YouTube videos to my site. When I copy and paste the URL into a YouTube Block it says to try again or it simply shows the URL of the YouTube video when previewing it instead of the video.

    How can I fix this?

    Thank you,

    Leo

    #1343913
    Leo
    Staff
    Customer Support

    Hi there,

    Any chance you can link us to the site in question?

    You can edit the original topic and use the private URL field.

    Let me know 🙂

    #1343941
    Downtown Spanish

    Dear Leo,

    Thank you for your time.

    I haven’t hired a Web Hosting service, the website isn’t public yet.

    I log in to my site on WordPress.org using Bitnami and edit it from there. How can I have you take a look at the issue?

    #1343945
    Leo
    Staff
    Customer Support

    I’m not sure if that’s possible unfortunately.

    Do you get the same issue with a twenty series WP theme?

    The YouTube block is from WordPress core.

    #1343959
    Downtown Spanish

    The videos also show up as URLs when I preview the site with the twenty twenty theme.

    No actual video are showing yet.

    I don’t understand why this is happening since I was able to embed videos when I downloaded GeneratePress on June 1st.

    #1343965
    Downtown Spanish

    Videos not embedding yet. Anyone experiencing the same issue?

    #1344031
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Any chance you share/take a screenshot of the exact error you’re facing?

    #1344059
    Downtown Spanish

    Hi Tom,

    Let me show you with the screenshots.

    This is what it looks like when I embed the videos on the edit page:

    https://ibb.co/nL78msP

    Sometimes these same videos look like this:

    https://ibb.co/w7sZJ4Y

    BUT, This is what it looks like when published or previewed:

    https://ibb.co/XDwDYk9

    #1344339
    David
    Staff
    Customer Support

    Hi there,

    it looks like your local server is having difficulty reaching the video server.
    Right Click > Inspect the page and see if there are any red errors in the console.

    #1344721
    Downtown Spanish

    Dear David,

    After inspecting the page, the YouTube Home Page shows 3 red signs and 1 yellow sign:

    https://ibb.co/9n2t9Jq

    When opening the video I am trying to embed, 6 red signs show up, sometimes 3 additional yellow signs:

    https://ibb.co/LJchdR0

    https://ibb.co/jMz0nyK

    https://ibb.co/qpYFn61

    How do I fix these errors so I can embed the videos into my GeneratePress Site?

    Thank you for taking the time to help me

    #1344817
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    Those errors are specific to YouTube – their developers will need to fix those. However, they shouldn’t be the cause of the issue you’re facing.

    Without seeing the site, it’s hard to debug. Do you have a live server you can test on? It could be a limitation of your local server preventing it from happening.

    If you have a live test sever and can get it to happen, it would help us figure out what’s going on, as we could dig into the code a bit.

    #1344902
    Downtown Spanish

    Tom,

    I am using Bitnami to edit my WordPress site

    I put the website URL on the first edit of this forum post so you can take a look at the code!

    Let me know if you can access it, otherwise, where do I get a live test server? Is Bitnami not one?

    #1345896
    Tom
    Lead Developer
    Lead Developer

    I’m not able to access that link, as it looks like it’s local to your computer. Is there a way to take it live? (I’m not familiar with Bitnami).

    #1345905
    Downtown Spanish

    How do I get it live? I am new to the tech world so any tips would be appreciated.

    #1345987
    Leo
    Staff
    Customer Support

    I would recommend checking with Bitnami’s support to see if there is way to generate a live link.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.