[Support request] Yoast Sitemap is errored when using Generatepress theme

Home Forums Support [Support request] Yoast Sitemap is errored when using Generatepress theme

Home Forums Support Yoast Sitemap is errored when using Generatepress theme

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #516623
    mmarvel

    Hello

    Suddenly my sitemap is not working. I get

    This page contains the following errors
    error at line 2 column 6: XML declaration allowed only at start of declaration

    After investigating this occurs because of conflict with theme or plugin that adds white or line to the beginning of the sitemap.xml file. When I go to where the file should reside and view page source, I see the first line of the sitemap.xml file is blank thus causing the error.

    I loaded the health check plugin to debug. It requires a default theme to be loaded to test each plugin to see when the sitemap.xml fails. I reloaded all plugins successfully with the sitemap.xml file functioning. I then loaded GP premium plugin but it requires the generatepress theme. As soon as both generatepress and GP were loaded the sitemap.xml errored out again.

    I’ve spent quite a few hours researching and testing but I stuck at this point with no idea how to resolve it.

    Can you assist?

    Thanks. Martha

    GeneratePress 2.0.2
    GP Premium 1.5.6
    #516764
    Tom
    Lead Developer
    Lead Developer

    Hi Martha,

    GeneratePress doesn’t do anything when it comes to sitemap.xml. You can see it functioning great here on this site: https://generatepress.com/sitemap.xml

    It might be worth checking with Yoast support. They can load up the free theme in a matter of minutes to test.

    There might be something corrupted within your sitemap, or possibly even a server setting.

    It might be an error they’re familiar with.

    Let me know 🙂

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.