Black Friday Sale! Get up to $40 off GP Premium!Learn more

[Resolved] woocommerce is breaking the site

Home Forums Support woocommerce is breaking the site

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #477679
    david

    everytime i activate woocommerce, everything else stops working. For instance, the customizer no longer publishes anything. the options to customize woocommerce dont even appear, i cant edit any page with elementor. i’ve increased memory, increased memory max limit, checked 404 pages, deleted pages and added new ones with new names for the shop page, i’ve increased my upload limit, bumped up php version to 7, deactivated all plugins and then activated them one by one. the problem at this point can only come down to two things, either woocommerce or the theme. i have this same setup with multiple themes but only the sites with this theme are not working once i activate woocommerce. i even tried deactivating the hooks for woocommerce to see if that would work but i keep getting the same results. please help. i need to make this work immediately

    GeneratePress 2.0.2
    #477684
    Tom
    Lead Developer
    Lead Developer

    Hi there,

    So if you keep everything the same and then activate a different theme, everything starts working fine?

    WooCommerce itself works with GP (you can see it here: http://demo.generatepress.com), so there has to be some sort of incompatibility coming from somewhere else.

    Anything recent in your error_log file?

    Any console errors if you right click the page and click “Inspect”?

    #478393
    david

    no none at all and yes it works with other themes. because there was a recent update with elementor and generatepress, i figured it had to be one of those. it seems like a weird combination of elementor pro, generatepress and woocommerce together. when i deactivate woocommerce, elementor and generatepress work fine. when i deactivate elementor pro, woocommerce and generatepress work fine. when i deactivate elementor pro, generatepress and woocommerce work fine. its crazy. i’ve solved any and all errors, added memory limits everywhere, and deactivated all other plugins. i’m in the middle of finishing a site for a client and this happened and now im stuck because i can’t implement their store. i cant customize generatepress when woocommerce is activated but it works but then i cant layout the pages because i cant even get to the page in elementor. updates killed me.

    #478394
    david

    by the way i activated oceanwp and hestia and it worked fine.

    #478541
    Tom
    Lead Developer
    Lead Developer

    Any chance you can send me temporary admin login details so I can take a look?: https://generatepress.com/contact/

    #481385
    david

    so i figured out the initial problem. it was stylepress plugin. i deleted it and the site came back, however, in the customization settings for the theme, there is no option for woocommerce. i have tried activating and deactivating it, same with the addon and it just isnt coming up. perhaps you can see what you can do. i’ll send you the login details right now as well. thanks for the help

    #481415
    Leo
    Staff
    Customer Support

    Just logged in and can see all the WooCommerce options.

    Check:
    Layout > WooCommerce
    Color > CooCommerce
    Typography > WooCommerce

    #482994
    david

    thanks. was i just looking in the wrong place the whole time or was the location changed with an update? either way, thank you

    #483145
    Leo
    Staff
    Customer Support
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.